Make WordPress Core

Opened 5 months ago

Closed 3 months ago

Last modified 3 months ago

#59828 closed defect (bug) (fixed)

Update npm packages with bugfixes for 6.4.3

Reported by: jorbin's profile jorbin Owned by: jorbin's profile jorbin
Milestone: 6.4.3 Priority: normal
Severity: normal Version:
Component: Editor Keywords: has-patch commit dev-reviewed
Focuses: Cc:

Description (last modified by SergeyBiryukov)

Some changes in the editor will need to be cherry picked and included in WordPress 6.4.3. This is a tracking ticket for those.

Change History (35)

#1 @jorbin
5 months ago

https://github.com/WordPress/gutenberg/pull/55361 is a bug that TT4 highlights and I think would be good to bring in the fix for.

#2 @kebbet
5 months ago

I’m adding this PR to get it on the radar here too.

It’s an issue with the context of multiple pattern strings.
https://github.com/WordPress/gutenberg/pull/55935

#3 @jorbin
5 months ago

  • Milestone changed from 6.4.1 to 6.4.2
  • Summary changed from Update npm packages with bugfixes for 6.4.1 to Update npm packages with bugfixes for 6.4.2

#4 @mikachan
5 months ago

#59898 was marked as a duplicate.

This ticket was mentioned in Slack in #core by mikachan. View the logs.


5 months ago

@isabel_brison commented on PR #5665:


5 months ago
#7

Noting that the following changes were also included in this PR:

Add check for lightbox values during image block migration

Add context for translators to any unclear usage of "synced"

Patterns: use existing download function for JSON downloads to fix no…

This is as expected because they were all marked for inclusion in the next minor release.

#8 @isabel_brison
5 months ago

In 57109:

Editor: update npm packages for 6.4.2.

Package updates with bug fixes related to patterns, Query look interactivity, design tools UI and accessibility.

Props mikachan, jorbin, kebbet, artemiosans, talldanwp, ramonopoly, alexstine, andrewserong, mamaduka, cbravobernal, ajlende, luisherranz.
See #59828.

#9 @isabel_brison
5 months ago

  • Keywords dev-feedback commit added

@isabel_brison commented on PR #5665:


5 months ago
#10

Committed in r57109. Leaving this open for commit to the release branch though not sure if it's best to point this PR at the release branch instead of trunk or just open a new one (we should in any case check CI passes with this diff against the release branch)

@mikachan commented on PR #5665:


5 months ago
#11

Thanks so much for helping with this and testing!

One thing I'm slightly puzzled about is why all the packages are getting version bumps.

This has been mentioned before during the 6.4 cycle but I can't find where right now. I vaguely remember it being mentioned and it was fine for now, but going into 6.5 maybe we should look more closely at this. 😅

I don't know if there's been an update to the publishing actions or if Lerna has been updated, but it's almost as if Lerna has no context for the current changes, so it assumes everything needs a version bump. I'm not sure what's changed between 6.3 and 6.4 though - maybe @gziolo knows more?

@gziolo commented on PR #5665:


5 months ago
#12

After checking the publishing job I can share that I identified the reason why we still see all packages published. I landed some time ago the fix in the Gutenberg repository that potentially addresses the issue encountered with https://github.com/WordPress/gutenberg/pull/55334 but it only impacts trunk. For not fully clear to me reasons, the publishing targeting the WP 6.4 release gets triggered from GitHub UI using the wp/6.4 branch. In effect, the publishing workflow doesn't use the patched version. To address it we should do two things:

  • Update the docs to make it clear that publishing workflow is triggered using the latest code from trunk.
  • Cherry-pick the linked PR to wp/6.4 in case the workflow get still triggered from the branch.

@mikachan commented on PR #5665:


5 months ago
#13

Ah this makes sense, thanks @gziolo! I hadn't seen https://github.com/WordPress/gutenberg/pull/55334.

For not fully clear to me reasons, the publishing targeting the WP 6.4 release gets triggered from GitHub UI using the wp/6.4 branch.

@SiobhyB and I discussed this early in the 6.4 cycle and we decided to go with publishing the packages targeting the wp/6.4 branch as we thought this was safer and would limit any potential unexpected issues, and we'd also seen a mix of publishing both from trunk and from the wp/X.Y branch in past runs. I guess we technically limited any issues but also missed a fix 😅

Update the docs to make it clear that publishing workflow is triggered using the latest code from trunk.

The docs screenshot does show the target as trunk, but this isn't mentioned in the text description. This sentence also threw me off: Now, the wp/X.Y branch is ready for publishing npm packages.. I had assumed this also meant "run from the wp/X.Y branch", so perhaps we could update this wording. It also didn't feel right to run the package updates from trunk, especially as all the other related work is based on the wp/X.Y branch.

Cherry-pick the linked PR to wp/6.4 in case the workflow get still triggered from the branch.

I'm happy to help handle this.

@isabel_brison commented on PR #5665:


5 months ago
#14

Oh I see, thanks @gziolo !

Update the docs to make it clear that publishing workflow should get triggered using the latest code from trunk.
Cherry-pick the linked PR to wp/6.4 in case the workflow get still triggered from the branch.

I agree with @mikachan that the docs could be more explicit about which branch to trigger the workflow from, as I also found that super confusing in the past 😅
Happy to go in and change that!

Cherry picking the fix to the release branch would also be good to avoid confusing anyone packaging a minor release from this branch in the future.

@gziolo commented on PR #5665:


5 months ago
#15

I cherry-picked https://github.com/WordPress/gutenberg/commit/1dd31459ba0a45c62adbcc4ae2fbd15dbed681e4 in the wp.6.4 branch in Gutenberg that should resolve the issue.

I agree with @mikachan that the docs could be more explicit about which branch to trigger the workflow from, as I also found that super confusing in the past 😅
Happy to go in and change that!

Let's do it as well, as it might prevent similar issues in the future. I understand how the combo box for selecting the branch might confuse people. The intention GitHub has with it is to allow the selection of the branch from which the GitHub workflow file is going to be read on CI. In effect, when selecting the wp/6.4 this is the current workflow (with the patch applied) that is going to get triggered:

https://github.com/WordPress/gutenberg/blob/wp/6.4/.github/workflows/publish-npm-packages.yml

This ticket was mentioned in Slack in #core by jorbin. View the logs.


5 months ago

@mikachan commented on PR #5665:


5 months ago
#17

Committed in r57109. Leaving this open for commit to the release branch though not sure if it's best to point this PR at the release branch instead of trunk or just open a new one (we should in any case check CI passes with this diff against the release branch)

@tellthemachines, you mentioned above that we may either need to point this PR at the release branch (I guess this is 6.4?) or open a new one. Which one would you recommend?

Also, we have one more change that needs to be included in the package update. I'm in the process of updating the packages again here - should I create a new PR for this, or include it in this PR? I know this PR has already been committed to trunk, so I'm guessing it's best to open a new PR.

@isabel_brison commented on PR #5665:


5 months ago
#18

Also, we have one more change that needs to be included in the package update.

@mikachan in that case it's probably easier to open a new PR for trunk with that extra change, and then assuming it's all good, open a third PR for the release branch including all the changes.

@mikachan commented on PR #5665:


5 months ago
#19

in that case it's probably easier to open a new PR for trunk with that extra change, and then assuming it's all good, open a third PR for the release branch including all the changes.

Will do, thank you!

@mikachan commented on PR #5665:


5 months ago
#22

Here's the new PR for trunk with the single extra change: https://github.com/WordPress/wordpress-develop/pull/5696

The tests seem good, although it looks like there's an error with the Playground build process here. I'm not sure if that's a blocker or not.

I went ahead and created a PR against the release branch too with all the changes: https://github.com/WordPress/wordpress-develop/pull/5698. All the tests passed here.

Thanks so much for your help 🙇

#23 @SergeyBiryukov
4 months ago

  • Description modified (diff)
  • Milestone changed from 6.4.2 to 6.4.3
  • Summary changed from Update npm packages with bugfixes for 6.4.2 to Update npm packages with bugfixes for 6.4.3

Looks like this was not backported to the 6.4 branch yet, renaming accordingly.

This ticket was mentioned in Slack in #core by jorbin. View the logs.


4 months ago

@mikachan commented on PR #5665:


3 months ago
#25

I'm going to close this PR as these changes have already been committed to trunk in r57109. We have multiple PRs open for the npm package update (including a separate PR for the release branch), so trying to reduce any confusion!

#26 @mikachan
3 months ago

Hi all. We currently have two PRs open for the npm updates for the next 6.4.x release:

I updated both of these today with the latest updates from the Gutenberg repo, so I believe they're ready to be tested and committed for the next point release.

#27 @jorbin
3 months ago

  • Keywords dev-reviewed added; dev-feedback removed
  • Owner set to jorbin
  • Status changed from new to assigned

Trunk was updated in [57258] with the PR from https://github.com/WordPress/wordpress-develop/pull/5696

https://github.com/WordPress/wordpress-develop/pull/5698 looks good to me for backporting to the 6.4 branch. Looking for a second committer to sign off.

This ticket was mentioned in Slack in #core by jorbin. View the logs.


3 months ago

This ticket was mentioned in Slack in #core by jorbin. View the logs.


3 months ago

This ticket was mentioned in Slack in #core by jorbin. View the logs.


3 months ago

#31 @peterwilsoncc
3 months ago

Signing off https://github.com/WordPress/wordpress-develop/pull/5698 for merging to the 6.4 branch.

Testing notes:

  • checkout out the pull request
  • run npm run sync-gutenberg-packages -- --dist-tag=wp-6.4
  • confirmed the changes in the PR still match the latest versions tagged for wp-6.4. They do.

Review notes:

  • confirmed the version bumps are in fact bumps. They are.

This ticket was mentioned in Slack in #core by peterwilsoncc. View the logs.


3 months ago

This ticket was mentioned in Slack in #core by jorbin. View the logs.


3 months ago

#34 @jorbin
3 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 57346:

Editor: update npm packages in trunk for 6.4.3.

Package Update includes fixes for:

  • Fix block rename control shown in "Advanced" for unsupported blocks
  • Query block: remove unnecessary class
  • Fix duotone not showing in site editor style block level styles
  • Query Loop - Add accessibility markup at the end of the loop in all cases.
  • Background Image Support: Hide the background image reset button when there's no image
  • Background image support: Fix focus loss when resetting background image
  • Autocomplete: Fix Voiceover not announcing suggestions
  • Fix pattern category renaming causing potential duplicate categories
  • Patterns: use existing download function for JSON downloads to fix non-ASCII encoding
  • Add context for translators to any unclear usage of "synced"
  • Image block: Add check for lightbox values during image block migration
  • Image Block: Enable image block to be selected correctly when clicked
  • Reduce specificity of default Cover text color styles.
  • Image Block: Fix deprecation when width/height attribute is number
  • Text selection: show CSS hack to Safari only.
  • SlotFill: Allow contextual SlotFillProviders

Reviewed by peterwilsoncc.
Merges [57258] and [57109] to 6.4 branch.

Props mikachan, isabel_brison, kebbet, artemiosans, talldanwp, ramonopoly, alexstine, andrewserong, mamaduka, cbravobernal, ajlende, luisherranz, wildworks, poena, czapla, andraganescu, joen, ellatrix, youknowriad, ntsekouras.
Fixes #59828.

@jorbin commented on PR #5698:


3 months ago
#35

This was merged in [57346]

Note: See TracTickets for help on using tickets.