Make WordPress Core

Opened 4 months ago

Closed 6 days ago

#59835 closed defect (bug) (worksforme)

Styling in Gutenberg is missing in 6.4

Reported by: rvervuurt's profile Rvervuurt Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.4
Component: Editor Keywords: has-screenshots reporter-feedback dev-feedback close
Focuses: css Cc:

Description

The standard-styling of Gutenberg text areas has been removed in 6.4:
https://i.imgur.com/QCBerta.png

The top two lines in this view are the title (normally huge) and the 2nd one is an h2-element:
https://i.imgur.com/pFYhaWH.png

When inspecting the element, it seems reset.css isn't properly applied:
https://i.imgur.com/vnrQPyL.png

If I add !important to the strike-through styles, it works properly:
https://i.imgur.com/Eqyzn5k.png

Seems to be a CSS specificity-error.

Change History (15)

#1 @Rvervuurt
4 months ago

Update: When changing to twentytwentyfour, some other styling is applied:
https://i.imgur.com/BxlAnrv.png

Reverting to 6.3.2 fixes the problem:
https://i.imgur.com/A893JhF.png

Is this something I have to fix in my custom theme? Or what is happening here?

Last edited 4 months ago by Rvervuurt (previous) (diff)

This ticket was mentioned in Slack in #core by jorbin. View the logs.


4 months ago

#3 @jorbin
4 months ago

While the issue is different, I wonder if the root cause is the same as #59847. Can you test the changeset there?

#4 @geoffreybr
4 months ago

We face the same issue and I tried to apply the changes from PR 5644 but it doesn't solve it.

Actually it comes from a change in wp-includes/css/dist/block-library/reset.css where all rules were prefixed with html selector prior to 6.4.

The change was introduced by this commit:
https://github.com/WordPress/gutenberg/commit/b18a270ae4b5d71cc0d880d40d21b5163686cd92?diff=unified#diff-bda8e417e9cfc8724167f4c82aab1d0d205245c51360a8afa4bba99ba078e6db

#5 @jorbin
4 months ago

Thanks @geoffreybr for investigating.

Tagging @ellatrix who committed the change referenced.

#6 @hellofromTonya
3 months ago

  • Keywords needs-patch removed
  • Milestone changed from Awaiting Review to 6.4.2
  • Severity changed from major to normal

The same Gutenberg PR referenced in this ticket has been referenced in Gutenberg issue 56293. I've reopened that Gutenberg issue and cross-linked it to this Trac ticket. That particular issue received a fix in relation to scope without specificity, which was merged earlier today into Gutenberg.

These 2 issues appear to be related to the same original Gutenberg commit and potentially other Trac reports of specificity.

Moving into 6.4.2 for monitoring / tracking. The work though will be done upstream in Gutenberg and when fixed, the corresponding fixes will get published in package updates and Core's package.json updated.

Last edited 3 months ago by hellofromTonya (previous) (diff)

#7 @SergeyBiryukov
3 months ago

  • Milestone changed from 6.4.2 to 6.4.3

This ticket was mentioned in Slack in #core-editor by jorbin. View the logs.


3 months ago

This ticket was mentioned in Slack in #core by jorbin. View the logs.


6 weeks ago

This ticket was mentioned in Slack in #core-editor by jorbin. View the logs.


6 weeks ago

This ticket was mentioned in Slack in #core by jorbin. View the logs.


6 weeks ago

#12 @jorbin
6 weeks ago

  • Milestone changed from 6.4.3 to 6.5

Based on lack of forward movement, I'm bumping this out of 6.4.3

#13 @swissspidy
2 weeks ago

  • Keywords reporter-feedback dev-feedback close added

Surely this must be fixed now with all the package updates in 6.5?

Can anyone confirm?

This ticket was mentioned in Slack in #core by rajinsharwar. View the logs.


10 days ago

#15 @swissspidy
6 days ago

  • Milestone 6.5 deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.