Make WordPress Core

Opened 3 months ago

Closed 2 months ago

#59850 closed defect (bug) (invalid)

Changing front-end site language changes some admin menu links into that language

Reported by: pierorocca's profile pierorocca Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: I18N Keywords: reporter-feedback
Focuses: Cc:

Description

Perhaps this is related to #49971, which I find fascinating that a platform of 20+ years hasn't quite sorted out language use case support.

On my us-EN site, with my admin profile set to English interface, if I set the site language to Italian for example, a collection of seemingly random menu links change from English into Italian. All the content is still in English however.

Make this make sense to me.

There are more menus that shown in the screen capture that are a mix of English and Italian link.

https://d.pr/i/zKSVqr

Change History (4)

#1 in reply to: ↑ description @pierorocca
3 months ago

Replying to pierorocca:

On my us-EN site, with my admin profile set to English interface, if I set the site language to Italian for example, a collection of seemingly random menu links change from English into Italian. All the content is still in English however.

admin links to be specific are changing into Italian

#2 @swissspidy
3 months ago

  • Keywords reporter-feedback added

Hi there and welcome to WordPress Trac

Since you are on WordPress.com, are you able to reproduce this on a fresh self-hosted WordPress installation? If not, I recommend reporting this on WordPress.com instead.

This ticket was mentioned in Slack in #core by jorbin. View the logs.


2 months ago

#4 @jorbin
2 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version 6.4 deleted

Based on no response to the request for feedback and no further reports of this, I'm closing this as invalid. If someone can reproduce on a fresh self-hosted WordPress installation, this should be reopened.

Note: See TracTickets for help on using tickets.