Make WordPress Core

Opened 8 months ago

Closed 8 months ago

#59872 closed defect (bug) (invalid)

WordPress 6.4.1 site doesn’t load with PHP8.2

Reported by: vidarparry's profile vidarparry Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.4
Component: Bootstrap/Load Keywords:
Focuses: Cc:

Description

My WordPress 6.4.1 site doesn’t load with PHP8.2 – it gets an error 500 on the GET command for the first file on page load. PHP 8.1 works fine.

I can’t find any error logs or seem to be able to diagnose this one to help you, sorry.

Change History (5)

#1 @rajinsharwar
8 months ago

Hi @vidarparry, thanks for your report, and sorry to hear that. Did you try with no-plugins activated, and with a default theme activated?

#2 @vidarparry
8 months ago

Hi @rajinsharwar . Thanks for the quick reply.
Yes, I tried twenty twentyfour and with all plugins disabled. Same result.

it is located in a subdomain, and a seperate subfolder under public_html (obviously), but this has worked with all previous versions of WP and PHP except the stated combination (WordPress 6.4.1 with PHP8.2).
Cheers
...Steve

#3 @antonvlasenko
8 months ago

Reproduction Report

Environment

  • WordPress: 6.4.1
  • PHP: 8.2.11
  • Server: Apache/2.4.57 (Unix) PHP/8.2.11
  • Database: mysqli (Server: 5.7.43 / Client: Unavailable)
  • Browser: Safari 17.1 (macOS)
  • Theme: Twenty Twenty-Four
  • MU-Plugins: None activated

Actual Results

  • ❌ When loading the WordPress site located in a subfolder, no error occurs.

Additional resources

https://cldup.com/wFTdBSwWRi.png

Additional Notes

I cannot reproduce this issue using PHP 8.2.11 on WordPress 6.4.1.

Last edited 8 months ago by antonvlasenko (previous) (diff)

#4 @vidarparry
8 months ago

Thank you.
I am also unable to reproduce this now.

However, a few days ago while investigating another issue my hosting provider advised "The issue was from our end with the PHP handler which has been resolved.".

Maybe that also fixed this one.

Either way, this ticket can be closed. Thank you to all for your help.

Cheers
...Steve

#5 @johnbillion
8 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Thanks for the update @vidarparry and glad you got it solved.

I'll close this as "invalid" which is just the unfriendly name used by our bug tracker to say that the ticket isn't a real bug. Cheers.

Note: See TracTickets for help on using tickets.