Make WordPress Core

Opened 6 months ago

Last modified 6 months ago

#59971 new defect (bug)

Publishing a post in QuickEdit forces Date to NOW

Reported by: snoffel's profile snoffel Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 6.4
Component: Quick/Bulk Edit Keywords: dev-feedback
Focuses: Cc:

Description (last modified by sabernhardt)

I use to give post-drafts a particular publishing date in the past (for ordering reasons when i publish them later on).

When I publish a post with a given date in Editing Mode, the publishing date stays my inserted day.
When I publish a post with a given date in Quick-Edit, the publishing date always gets forced to NOW.
(This also happens when I bulk-edit several posts)

I checked that with older versions: Until WordPress 6.2.3 it was possible to publish a post with Quick-Edit and keep my given publishing date. It also worked when bulk-editing several posts.

I think this might be a bug, maybe somehow related to the fixed ticket #59125?

Change History (3)

#1 @sabernhardt
6 months ago

  • Description modified (diff)

#2 @azaozz
6 months ago

  • Keywords dev-feedback added

When I publish a post with a given date in Quick-Edit

Not really sure what you mean by "publishing in Quick Edit". Yes, you can change the post status there (draft, published, etc.) but that's not a place to publish posts :)

Think there will be several steps missing when you "publish" by only changing the post status, not sure that should be supported? So the issue here is probably that it is possible to publish a post for the first time from Quick Edit, not that it sets the current date and time. Thinking that should not be possible, perhaps? Tagging with dev-feedback for more opinions.


#3 @snoffel
6 months ago

Thanks for your feedback, azaozz!

For me sorting several articles by date and then publishing them via Quick-Edit always worked fine, i never felt there could be "missing steps" in doing so (but maybe i missed something?)

As a user, I finde inside Quick-Edit an interface for giving a date and publishing, so my expection was, that it works that way. Furthermore it did work like this without a problem for years, I use it this way since WordPress 5x until Version 6.2.3 - so this change felt like a bug to me.

I'm curious to see what others say about this.

Note: See TracTickets for help on using tickets.