Make WordPress Core

Opened 8 months ago

Last modified 6 months ago

#59979 new feature request

Add a wp_mail() check to Site Health Info

Reported by: lakshmananphp's profile lakshmananphp Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version:
Component: Site Health Keywords: close
Focuses: Cc:

Description (last modified by SergeyBiryukov)

Check whether the site can send emails via wp_mail() and add the status information to Site Health.

This would help debug email deliverability.

Related ticket: #22837

Change History (5)

This ticket was mentioned in Slack in #core by lakshmananphp. View the logs.


8 months ago

#2 @oglekler
8 months ago

This was discussed during a bug scrub. When site cannot send email, I am considering it as a critical issue and Site Health holds no information about this. I believe that there are two options - to send generic email so site admin while checking this ability or to store the information about failures if they are happening. This issue can be temporary or permanent so, by having this information site owner can make some reasonable decision to use a plugin, to change setting or adjust hosting permissions.

#3 @oglekler
8 months ago

  • Version 6.4 deleted

I am removing version because this is true for all previous WP versions.

#4 @Clorith
8 months ago

  • Keywords close added

To test email deliverables properly, you need to actually send an email; having Site Health do this automatically will quite often be considered spam, and is unfortunately not something that WordPress can do.

That said, the Health Check plugin has this specific tool available, and anyone needing to test their emails can use the plugin, as the testing is then caused by a users direct action.

Due to the above mentioned concerns and restrictions, I'm going to recommend this be closed as wontfix.

#5 @SergeyBiryukov
6 months ago

  • Description modified (diff)
Note: See TracTickets for help on using tickets.