Make WordPress Core

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#59985 closed defect (bug) (duplicate)

Language "German (Austria)" outputs html lang incorrectly as "de-DE" not "de-AT"

Reported by: crascher's profile crascher Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.4
Component: I18N Keywords:
Focuses: Cc:

Description

Hi, the problem seems to be old or to be back since some time.

The lang attribute in the html tag for the language/translation "German (Austria)" is incorrectly output as "de-DE". This would be correct for plain German, but for the region of Austria it should be "de-AT".

See also here: https://core.trac.wordpress.org/ticket/55412

This is quite a problem for us because we have different pages in Germany and Austria. To have for both pages de-DE is impacting our SEO setup.

Change History (2)

#1 @swissspidy
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Severity changed from major to normal
  • Status changed from new to closed

Hi and welcome to WordPress Trac!

As you have already seen #55412, this is really a duplicate. This is not an issue with WordPress core, but the de_AT translation.

See https://translate.wordpress.org/projects/wp/dev/de-at/default/?filters%5Bterm%5D=lang_attribute&filters%5Bterm_scope%5D=scope_any&filters%5Bstatus%5D=current_or_waiting_or_fuzzy_or_untranslated&filters%5Buser_login%5D=&filter=Apply+Filters&sort%5Bby%5D=priority&sort%5Bhow%5D=desc

I recommend you to reach out to the de_AT translation team via https://de-at.wordpress.org/slack-austria-wp-community/

cc @pputzer

#2 @pputzer
3 months ago

Thanks for the heads up. Looks like we missed this when manually copying translations from the German project. Fixed for the last few versions.

Note: See TracTickets for help on using tickets.