Make WordPress Core

Opened 8 months ago

Last modified 7 weeks ago

#59986 new enhancement

Add a filter into the $wp_meta_boxes output loop to provide the ability to change data

Reported by: oglekler's profile oglekler Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version:
Component: Posts, Post Types Keywords:
Focuses: administration Cc:

Description

I have a metabox added via plugin that connects a custom post type with users. But I don't like the name of the Meta Box, it obscures the purpose of the box. So, the plugin doesn't have this option, and I have to change global $wp_meta_boxes for the desired effect, which isn't the correct thing to do. Of course, I could write a plugin author plea to add a filter (and it will be the third "brilliant idea" from me in two days 🙈), but it is possible to stumble across this need with another plugin as well. This is why I think it is necessary to add the filter to the core.

Related ticket: https://core.trac.wordpress.org/ticket/39969

Attachments (1)

2023-11-29_16-42-06.png (18.5 KB) - added by oglekler 8 months ago.

Download all attachments as: .zip

Change History (4)

#1 @swissspidy
8 months ago

Can't the global be modified directly?

Of course, I could write a plugin author plea to add a filter (and it will be the third "brilliant idea" from me in two days 🙈)

FWIW, Posts 2 Posts is not maintained anymore, so if you have any feature requests for that plugin it's easiest to just fork it and add whatever feature you need yourself.

#2 @oglekler
8 months ago

@swissspidy the global can be modified directly, yes, and I did exactly this, but this isn't the right way to do it.

https://wordpress.org/plugins/posts-to-posts/ - plugin is maintained or supported somehow, possibly just updated from another repo 🤔 But if it is really not maintained properly, my problems multiply.

Still, this is only one case when you can modify information, and possibly there are other cases. I think the ability to add a description or something else into the metabox is also a possibility: #39969

#3 @oglekler
7 weeks ago

  • Type changed from defect (bug) to enhancement
Note: See TracTickets for help on using tickets.