Make WordPress Core

Opened 6 months ago

Closed 6 months ago

Last modified 4 months ago

#60058 closed defect (bug) (duplicate)

SQL_CALC_FOUND_ROWS is deprecated in MySQL 8.0.17

Reported by: johnstonphilip's profile johnstonphilip Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.5
Component: General Keywords:
Focuses: Cc:

Description

I stumbled on this notice that is being deprecated in MySQL 8.0.17. See:
https://dev.mysql.com/doc/refman/8.0/en/information-functions.html#function_found-rows

I also see WordPress uses it in a few places:
https://github.com/search?q=repo%3AWordPress%2Fwordpress-develop%20SQL_CALC_FOUND_ROWS&type=code

I haven't had time to dig in further but I wanted to flag it just in case it hasn't been yet.

Change History (2)

#2 @johnbillion
6 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the report, this is a duplicate of #47280 which has stalled for a while as it's not clear how this change can be made in a fully backwards compatible manner.

Note: See TracTickets for help on using tickets.