Make WordPress Core

Opened 4 months ago

Closed 4 months ago

Last modified 2 months ago

#60088 closed defect (bug) (duplicate)

Visual Editor can't select text Chrome Beta, Dev, Canary and Chromium

Reported by: rybtechsupport's profile rybtechsupport Owned by:
Milestone: Priority: normal
Severity: critical Version: 6.4.2
Component: Editor Keywords:
Focuses: Cc:

Description

I can confirm in Chrome Beta, Dev, Canary and Chromimum you cannot select text in Visual Editor.

I have multiple computers with Chrome Beta and Dev with no extentions, different google accounts for different freelancing projects and about a week or so ago the updates caused this bug, I can select text any where else in WordPress, including code editor or classic editor but not visual editor

I cant double click also anything or select all of the blocks

I am not sure if this is due to privacy as the goal of Chrome is going privacy, but I reset, uninstalled , put in sandbox and no matter what I do or what computer the bug is there.

I can confirm on Chrome - Version 120.0.6099.110 (Official Build) (64-bit) this bug does not exisit, but since Google ports some of the Beta/Dev settings to Chrome, I think it will eventually come to Chrome

Change History (2)

#1 @swissspidy
4 months ago

  • Component changed from General to Editor
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi there and welcome to WordPress Trac.

We're already tracking this in #59943 and https://github.com/WordPress/gutenberg/issues/56408.

The issue is not that text selection is not working, but that there is no color anymore.

#2 @ecuzebagixaw1982
2 months ago

Thank you for bringing this issue to our attention. The inability to select text in the Visual Editor of WordPress while using Chrome Beta, Dev, Canary, and Chromium browsers is indeed a significant problem that can hinder productivity and user experience for many WordPress users. Your detailed description of the issue, including multiple instances across different computers and versions of Chrome, suggests that this is a widespread and persistent issue that needs to be addressed promptly.

Based on your description, it seems that this issue is specific to the Visual Editor in WordPress and is not affecting other parts of the WordPress admin interface or other websites in the Chrome Beta, Dev, Canary, and Chromium browsers. This indicates that the problem is likely related to the interaction between the Visual Editor and the browser environment rather than a general issue with text selection in Chrome.

Given that the problem started occurring about a week ago after updates to Chrome Beta, Dev, Canary, and Chromium, it's possible that the updates introduced a compatibility issue or bug that is affecting the functionality of the Visual Editor. It's also worth considering whether any recent changes to the WordPress core or plugins could be contributing to the issue.

To address this problem, there are several steps that can be taken:

  1. Report the Issue: It's essential to report this issue to both the WordPress development team and the Chrome development team. Providing detailed information about the problem, including browser versions, operating system, and any relevant error messages, can help developers identify and fix the issue more effectively.
  1. Temporary Workarounds: While waiting for a permanent solution, users affected by this issue can consider using alternative browsers or the Classic Editor plugin as a temporary workaround. The Classic Editor provides a familiar editing experience similar to the previous WordPress editor and may not be affected by the same compatibility issues.
  1. Monitor for Updates: Keep an eye on updates for both WordPress and Chrome to see if any patches or fixes are released to address this issue. It's possible that future updates to either the browser or the WordPress core could resolve the problem.
  1. Check for Plugin Compatibility: If you're using any plugins or themes that interact with the Visual Editor, make sure they are compatible with the latest versions of WordPress and Chrome. Incompatibilities with third-party code could exacerbate the issue.
  1. Consider Browser Settings: Review browser settings and configurations to see if any changes can mitigate the problem. This could include adjusting privacy settings, disabling extensions, or clearing browser cache and cookies.
  1. Community Support: Reach out to the WordPress community forums or relevant online communities to see if other users are experiencing similar issues and if any community-generated solutions or workarounds are available.

In summary, the inability to select text in the Visual Editor of WordPress while using Chrome Beta, Dev, Canary, and Chromium browsers is a significant issue that requires attention from both the WordPress and Chrome development teams. By reporting the issue, exploring temporary workarounds, monitoring for updates, checking for plugin compatibility, reviewing browser settings, and seeking community support, affected users can work towards resolving the problem and restoring full functionality to the Visual Editor. Thank you for bringing this issue to our attention, and I hope these suggestions prove helpful in addressing the problem.

Note: See TracTickets for help on using tickets.