Make WordPress Core

Opened 6 months ago

Last modified 7 weeks ago

#60129 reopened task (blessed)

Comment on a PR when no Trac ticket is included

Reported by: desrosj's profile desrosj Owned by: desrosj's profile desrosj
Milestone: 6.6 Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords: good-first-bug has-patch commit
Focuses: Cc:

Description

When contributing to Core using a pull request on GitHub, a Trac ticket is required for the contribution to be considered.

Even though the pull request template notes this, it's easy to forget or overlook.

Adding a job in the Pull Request Comments workflow to add a reminder comment when a Trac ticket link is missing is an easy way to help avoid contributions being lost in the shuffle.

Change History (16)

This ticket was mentioned in PR #6060 on WordPress/wordpress-develop by @anamarijapapic.


5 months ago
#1

  • Keywords has-patch added; needs-patch removed

When contributing to Core using a pull request on GitHub, a Trac ticket is required for the contribution to be considered.

Even though the pull request template notes this, it's easy to forget or overlook.

Adding a job in the Pull Request Comments workflow to add a reminder comment when a Trac ticket link is missing is an easy way to help avoid contributions being lost in the shuffle.

Trac ticket: https://core.trac.wordpress.org/ticket/60129

This ticket was mentioned in PR #6088 on WordPress/wordpress-develop by @desrosj.


4 months ago
#2

Trac ticket:

@desrosj commented on PR #6060:


4 months ago
#3

Was thinking about this a bit more today. I think we should also attempt to check if a previous comment exists to avoid multiple comments for the same thing on a PR.

@anamarijapapic commented on PR #6060:


4 months ago
#4

Thank you for the review @desrosj and @peterwilsoncc!

I'll make the requested changes in the next few days when I have some free time. Feel free to let me know if you have any further suggestions!

This ticket was mentioned in Slack in #core by desrosj. View the logs.


4 months ago

#7 @swissspidy
4 months ago

  • Type changed from defect (bug) to task (blessed)

#8 @swissspidy
4 months ago

  • Milestone changed from 6.5 to 6.6

#9 @devsahadat
3 months ago

It's crucial to remember including a Trac ticket link when contributing to WordPress Core via a GitHub pull request. Despite the reminder in the template, oversight happens.
Implementing a job in the PR Comments workflow to prompt for a missing Trac ticket link could prevent contributions from slipping through. Additionally, considering @anamarijapapic's suggestion to avoid duplicate comments on PRs would streamline the process further.

#10 @anamarijapapic
3 months ago

@desrosj @peterwilsoncc @swissspidy Any updates on this?

#11 @desrosj
7 weeks ago

  • Keywords commit added
  • Owner set to desrosj
  • Status changed from new to accepted

Hi @anamarijapapic! Thanks for working on this, and apologies it took so long to circle back to!

I think that this looks to be in a good state. Let's give it a try!

#12 @desrosj
7 weeks ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 58092:

Build/Test Tools: Remind contributors to include a Trac ticket link.

Contributing to WordPress using wordpress-develop on GitHub is a useful way collaborate, test, and review suggested changes to the code base. One of the required criteria, though, is including a link to a corresponding Trac ticket. This ensures the PR and associated activity is listed on the Trac ticket, which serves as the source of truth.

It’s easy to forget this and newer contributors aren’t always aware of this requirement. This adds a GitHub Actions job that will add a comment as a reminder when no Trac ticket is included.

Is the waiting really ended? Two thousand years.

Props anamarijapapic, peterwilsoncc.
Fixes #60129.

#14 @ocean90
7 weeks ago

Should the comment be deleted once the link has been added?

#15 @desrosj
7 weeks ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

@ocean90 That's probably a good idea to limit the number of bot comments on the PR.

Looks like there is an edited activity type for pull_request_target/pull_request that could be used for this.

#16 @desrosj
7 weeks ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 58120:

Build/Test Tools: Remove check-latest input for setup-node.

The check-latest setting is used to ensure the latest version of Node.js is always installed in GitHub Action workflows.

This input was added and turned on in [57212] when the minimum required version of Node.js was bumped to 20.10.0. Because GitHub Action runner image updates are deployed on a rolling basis over the course of several days, a version of Node.js that met this new requirement was not always present (especially on Windows runners). Using this input was a temporary fix to ensure stability for Core’s test workflows.

The check-latest input does have some side effects. Two examples are:

  • An additional request is performed to check the latest version every time setup-node is used with this option enabled. More requests are made to download and install a newer version of Node.js when one is available.
  • When new versions of Node.js are released, the Core workflows immediately switch to the new version, which could potentially have undiscovered bugs or regressions.

The latter has surfaced today due to a regression in Node.js 20.13.0 on Windows (see https://github.com/nodejs/node/issues/52884).

A bit of time has passed and a version >=20.10.0 is now reliably available on all GitHub Action runners. Running the very latest release Node.js is also not important for Core’s testing setup, so check-version can safely be removed to address both side effects detailed above.

Props johnbillion.
Fixes #60129.

#17 @johnbillion
7 weeks ago

  • Resolution fixed deleted
  • Status changed from closed to reopened
Note: See TracTickets for help on using tickets.