WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6017 closed defect (bug) (duplicate)

Delete buttons doens't ask for confirmation

Reported by: SteveAgl Owned by:
Milestone: Priority: high
Severity: critical Version: 2.5
Component: Administration Keywords:
Focuses: Cc:

Description

In manage post, pages media and i suppose other manage pages, when you select elements and then click te delete button they get deleted without any confimation message box appears. This is a very bad and dangerouse behave that differ from the usuale way delete buttons works.

Change History (4)

comment:1 @SteveAgl7 years ago

  • Summary changed from Dlete buttons doens't ask confirmation to Delete buttons doens't ask for confirmation

comment:2 @thee177 years ago

  • Milestone 2.5 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

To quote 5883

This behavior is unlikely to change for this release. As this is the behavior Matt prefers http://wpdevel.wordpress.com/2008/02/09/restore-ays-for-deletes/

Mark Jaquith suggested an undo like system for a future release, but I don't think anyone has worked on it (yet): #4529: Modal "Are You Sure?" dialogs should be replaced with "Undo" functionality

Also this is a duplicate of 5370

comment:3 follow-up: @SteveAgl7 years ago

Matt asked not have AYS in deleting comments, and this should be ok on bulk editing for comments but it's unacceptable for other situations (deleting a post or pages should be carefully confirmed!!

And even for comments (but there an undo method would be ok. Really, if Matt would like having random comments deleted based on astrological method thiis would be taken as the verb? Al sw ask confirmation before deleting stuff, and this in every O.S... so I don't see why WP should go for another path

comment:4 in reply to: ↑ 3 @lloydbudd7 years ago

Replying to SteveAgl:

Matt asked not have AYS in deleting comments, and this should be ok on bulk editing for comments but it's unacceptable for other situations (deleting a post or pages should be carefully confirmed!!

As thee17 wrote, this is a duplicate of #5370 .

Note: See TracTickets for help on using tickets.