Make WordPress Core

Opened 4 months ago

Closed 4 months ago

#60251 closed defect (bug) (duplicate)

NOT SURE what to do with thie NOTICE MESSAGE SHOWN IN Customize Screen

Reported by: kazskater99's profile kazskater99 Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.4.2
Component: Menus Keywords:
Focuses: Cc:

Description (last modified by sabernhardt)

Notice: Trying to get property 'post_status' of non-object in /.../wp-admin/includes/template.php on line 2298

Notice: Trying to get property 'post_status' of non-object in /.../wp-admin/includes/template.php on line 2302

Notice: Trying to get property 'post_status' of non-object in /.../wp-admin/includes/template.php on line 2308

Notice: Trying to get property 'post_status' of non-object in /.../wp-admin/includes/template.php on line 2312

Notice: Trying to get property 'ID' of non-object in /.../wp-admin/includes/template.php on line 2316

Notice: Trying to get property 'post_status' of non-object in /.../wp-admin/includes/template.php on line 2320

Notice: Trying to get property 'ID' of non-object in /.../wp-admin/includes/template.php on line ...

Change History (5)

#2 @sabernhardt
4 months ago

  • Description modified (diff)

Hi and welcome to WordPress Core Trac!

This issue may be related to #51565 and/or #58044.

#3 @kazskater99
4 months ago

Thank you VEry much for notice.

I actually had empty location menu which supposed to be delated.

i delated. no more NOTICE message shown up.

Thank you.

#4 @kazskater99
4 months ago

Do you know I have notice few days ago.

Message is here shown

Notice: Function wp_enqueue_script() was called incorrectly. "wp-editor" script should not be enqueued together with the new widgets editor (wp-edit-widgets or wp-customize-widgets). Please see Debugging in WordPress for more information. (This message was added in version 5.8.0.) in /.../wp-includes/functions.php on line 6031

I am doing this not to show message.

function example_theme_support() {
    remove_theme_support( 'widgets-block-editor' );
}
add_action( 'after_setup_theme', 'example_theme_support' );

Thank you

Last edited 4 months ago by sabernhardt (previous) (diff)

#5 @sabernhardt
4 months ago

  • Component changed from General to Menus
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

I'll close the ticket as a duplicate of #51565 then.

For individual site help, please use the support forums. See especially this topic for the widget editor:
https://wordpress.org/support/topic/error-in-widgets-with-new-wordpress-version-5-8-wp_enqueue_script-and-wp/

Note: See TracTickets for help on using tickets.