Make WordPress Core

Opened 3 months ago

Closed 3 months ago

#60376 closed feature request (duplicate)

WordPress by default violates GDPR with wpEmojiSettingsSupports cookie

Reported by: gemonon's profile gemonon Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.4.2
Component: Emoji Keywords:
Focuses: privacy Cc:

Description

Hey there,

with this change, I believe, (https://core.trac.wordpress.org/ticket/58663), a cookie wpEmojiSettingsSupports was introduced in default WordPress installations, which breaks the GDPR regulations in Europe by default.

Please make this optional and off by default - this seriously risks the GDPR compliance in standard installations from the very first second. We already nearly faced fines in Germany due to an Elementor Pro cookie being automatically set and Elementor ignores the issue to this date, for users in Europe having to resort to hoping, that custom coding scripts won't break (see here for reference: https://github.com/elementor/elementor/issues/7151 ).

Warm regards and thanks for all your hard work,
Georg

Change History (1)

#1 @swissspidy
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Severity changed from major to normal
  • Status changed from new to closed

Hi there and welcome to Trac!

I am closing this as a duplicate of #59445 where this was raised before. That one was closed with the following reason:

The advice from the project's lawyers is that the emoji detection changes aren't required to be reverted

Note: See TracTickets for help on using tickets.