Make WordPress Core

Opened 5 months ago

Closed 2 months ago

Last modified 2 months ago

#60435 closed defect (bug) (worksforme)

Twenty Twenty-Four: Footnotes Icon not showing on Mac OS Sonoma 14.3 and Safari 17.3

Reported by: jordesign's profile jordesign Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.4.3
Component: Bundled Theme Keywords: has-patch needs-testing 2nd-opinion close
Focuses: Cc:

Description

When updated to the latest Mac OS (Sonoma 14.3) and using Safari 17.3 - the arrow icon for footnotes (at the bottom of the page) does not display. The inline footnote arrow shows - just not the one at the bottom of the content.

This seems related to the font face - if I change to default sans-serif, the arrow displays once again.

https://s3.amazonaws.com/i.snag.gy/dR6Xwz.jpg

Attachments (1)

footnotes.jpg (26.3 KB) - added by kafleg 3 months ago.

Download all attachments as: .zip

Change History (24)

#1 @jharries
5 months ago

@jordesign Thanks for putting that up as a bug.

One other thing that may help: I can duplicate this on my docker dev site in vanilla 2024, and in the theme I’m working on which uses some of the Theme.Json from 2024 (not child).

But when I subsetted the Inter default body font and loaded that as woff2, using the load local font function of the Create Block Theme plugin, rather than the load Google font function, it works fine.

Sorry I’m not enough of a developer to speculate on why this is, but hopefully it will clue someone with more knowledge in to the cause.

Hope that’s helpful.

#2 @jharries
5 months ago

I will also leave this test site up for a while so others can check out the behaviour. It's a clean install running 2024 with no modifications and no added plugins: https://aacdebug.kinsta.cloud/?p=28

This ticket was mentioned in Slack in #core-test by ankit-k-gupta. View the logs.


5 months ago

#4 @huzaifaalmesbah
5 months ago

Reproduction Report

I was able to replicate this issue.

Environment

  • WordPress: 6.5-alpha-56966-src
  • PHP: 8.2.14
  • Server: nginx/1.25.3
  • Database: mysqli (Server: 5.7.44 / Client: mysqlnd 8.2.14)
  • Browser: Safari 17.3
  • OS: macOS
  • Theme: Twenty Twenty-Four 1.0
  • MU Plugins: None activated
  • Plugins:
    • Test Reports 1.0.1

https://i.ibb.co/Ss5Qw7K/Screenshot-2024-02-06-at-11-49-58-PM.png

Last edited 5 months ago by huzaifaalmesbah (previous) (diff)

#5 @poena
5 months ago

  • Component changed from Themes to Bundled Theme

#6 @poena
5 months ago

  • Milestone changed from Awaiting Review to 6.5

I can reproduce the problem too after updating to 14.3.

Replacing the current font file with Inter version 4 from https://github.com/rsms/inter/releases
and clearing cache solves it for me.

#7 @poena
5 months ago

I think the font file name needs to be the same, since users may have global styles data saved with the current file name from theme.json.

Last edited 5 months ago by poena (previous) (diff)

This ticket was mentioned in PR #6080 on WordPress/wordpress-develop by @poena.


5 months ago
#8

  • Keywords has-patch added; needs-patch removed

Trac ticket: https://core.trac.wordpress.org/ticket/60435

Twenty Twenty-Four: Update to Inter version 4 to resolve icon issue in Safari
Replaces the existing font file Inter-VariableFont_slnt,wght.woff2 with a new version.

#9 @poena
5 months ago

  • Keywords needs-testing added

Twenty Twenty: No issues found.
Twenty Twenty-Three: No issues found. I would appreciate if someone could double check this.

#10 @poena
5 months ago

Doh, the problem did not show up in Twenty Twenty-Three because it does not use Inter as default for the foot notes. When switching to Inter, the problem is visible.

#11 @poena
5 months ago

I need some help with finding a suitable replacement font file for Twenty Twenty-Three.

The current file is the combined variable .ttf font: Inter-VariableFont_slnt,wght.ttf from Google fonts, but Google fonts is not providing the updated version.
-That is, if I download the font from Google Fonts today and replace the file in the theme, the problem with the missing footnote icon is not solved.
https://fonts.google.com/specimen/Inter

While if I download version 4 of Inter from https://github.com/rsms/inter/releases,
It has two variable .ttf files: InterVariable.ttf and InterVariable-Italic.ttf.

Which would be the matching replacement?

#12 @poena
5 months ago

  • Milestone changed from 6.5 to Future Release

#13 @poena
5 months ago

  • Milestone changed from Future Release to 6.6

This ticket was mentioned in Slack in #core-themes by karmatosed. View the logs.


3 months ago

#15 @poena
3 months ago

  • Keywords needs-refresh dev-feedback added; has-patch removed

#16 @luminuu
3 months ago

Have tested this on Sonoma 14.4.1 and Safari 17.4.1 and the icon is showing for me.

#17 @kafleg
3 months ago

  • Keywords has-patch added; needs-refresh dev-feedback removed

I tested in Windows,

WordPress: 6.5.2
PHP: 8.2.14
Browser: Edge
OS: macOS
Theme: Twenty Twenty-Four 1.1
MU Plugins: None activated

Not able to reproduce the issue.

@kafleg
3 months ago

#18 @sabernhardt
3 months ago

  • Summary changed from Footnotes Icon not showing for TT4 on Mac OS Sonoma 14.3 and Safari 17.3 to Twenty Twenty-Four: Footnotes Icon not showing on Mac OS Sonoma 14.3 and Safari 17.3

#19 @poena
2 months ago

I no longer have macOS Sonoma 14.3 so I can't test on that version anymore.

on Sonoma 14.4.1 with Safari 17.4.1, I see the icon without any patch needed.

#20 @poena
2 months ago

  • Keywords 2nd-opinion close added

I suggest closing it as "worksforme", as a browser bug with this font that has been fixed?
Or do we need to wait until a few more version upgrades have happened?

(I am still not sure how to update the font correctly though.)

#21 @karmatosed
2 months ago

  • Milestone 6.6 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I agree with @poena on this so will close for now. Thank you everyone for your collaboration on this. I think closing now and then we can always have a new ticketed opened if needed.

#22 @sabernhardt
2 months ago

I agree with closing the ticket. However, if a committer wants to update font files, that could be good for other reasons too.

#23 @poena
2 months ago

Yeah, I feel like updating the font files may be something that should be one at least once per year. perhaps it could be a task for every major release, or the last major release of the year.

Note: See TracTickets for help on using tickets.