Make WordPress Core

Opened 5 months ago

Closed 5 months ago

#60444 closed defect (bug) (duplicate)

Shortcode Rendering Issue After WordPress Update with block_template_part()

Reported by: ionpulbere's profile ionpulbere Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.4.3
Component: Shortcodes Keywords:
Focuses: Cc:

Description

Hi,

We recently performed an update on our WordPress website to the latest version, 6.4.3. However, we have encountered an issue where the shortcodes are not rendering as expected.

This problem specifically arises when the shortcodes are added in the block template and an attempt is made to display them using block_template_part(). It's worth mentioning that the shortcodes were rendering successfully on WordPress version 6.2.

See images attached:
1)WP 6.4.3 - https://ibb.co/qFpH2Zm
2)WP 6.2 - https://ibb.co/BqgmcrG

Could you please investigate and provide a solution for this issue at your earliest convenience? Your prompt attention to this matter would be highly appreciated.

Thank you for your assistance.

Best regards,
Ion

Attachments (2)

wp6.4.3.jpeg (152.3 KB) - added by ionpulbere 5 months ago.
6.4.3
wp 6.2 - ok.jpeg (117.3 KB) - added by ionpulbere 5 months ago.
6.2

Download all attachments as: .zip

Change History (5)

@ionpulbere
5 months ago

6.4.3

@ionpulbere
5 months ago

6.2

#1 @poena
5 months ago

  • Keywords reporter-feedback added
  • Severity changed from major to normal

Hi @ionpulbere
I believe this is a duplicate of the issue that is being tracked here:
https://core.trac.wordpress.org/ticket/56780
Can you please confirm?

The issue specifically mentions classic themes that support block based template parts. In your case, from looking at the screenshots, it looks like you have turned Twenty Twenty-Four into a hybrid theme using PHP templates, using the same functionality as a classic theme that supports block based template parts.

#2 @ionpulbere
5 months ago

Hi,

Yes, it looks like the issue that I reported and https://core.trac.wordpress.org/ticket/56780 are similar.

#3 @poena
5 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #56780.

Thank you. Then let's close this: it makes them easier to manage.

Note: See TracTickets for help on using tickets.