WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#6045 closed defect (bug) (wontfix)

Flash Uploader Issues on Shared account (dealing with Flash on OS X)

Reported by: anthonycole Owned by: anthonycole
Milestone: Priority: normal
Severity: normal Version: 2.5
Component: General Keywords: reporter-feedback
Focuses: Cc:

Description

So I have an interesting bug that I'm dealing with.

Basically, I can't upload _anything_ whatsoever. I've been hitting myself over the head all night dealing with this. At first I thought it was a permissions issue. Oddly enough, permissions were fine.

So I did what any person in there right mind would do and did a google of the message I was getting - "HTTP Error".

Turns out it's a flash issue. I stumbled on http://swfupload.org/forum/generaldiscussion/268 and http://livedocs.adobe.com/flash/8/main/wwhelp/wwhimpl/common/html/wwhelp.htm?context=LiveDocs_Parts&file=00002216.html. They give an alternative solution, but I'm not sure how it could be implemented.

I'm using a shared account on asmallorange. My root directory is ~/public_html (with no wordpress install) and the install is in ~/domains/creativepunks.com,(a parked domain) with flash 9 on OS X.

Attachments (1)

Picture 1.png (208.1 KB) - added by anthonycole 6 years ago.
Error

Download all attachments as: .zip

Change History (8)

anthonycole6 years ago

Error

comment:1 andy6 years ago

  • Keywords reporter-feedback added
  • Milestone changed from 2.6 to 2.5
  • Owner changed from anonymous to anthonycole
  • Priority changed from normal to high
  • Version set to 2.5

Please "view source" on the uploader iframe and look at the swfupload config array, which you will find in a script tag. Does the upload_url setting have the correct path to async-upload.php?

That is set up in wp-admin/includes/media.php:

$flash_action_url = get_option('siteurl') . "/wp-admin/async-upload.php";

comment:2 mdawaffe6 years ago

IIRC, the original poster said on IRC that he gets this error message in all browsers under OS X, but on no browsers under windows.

comment:3 andy6 years ago

  • Priority changed from high to normal
  • Resolution set to wontfix
  • Status changed from new to closed

I worked directly with the reporter today. On his shared account with a forwarded domain, the uploader sends a well-formed POST to the correct URL. The response is a 301 (Moved Permanently) to the same URL plus a trailing slash (async-upload.php/). This much happens regardless of platform.

In Windows, the Flash uploader succeeds. In OS X, it fails and gives the user the HTTP Error. We modified async-upload.php to dump $_POST as a first line and this was not caught by the uploader, so it looks like the 301 is not coming from the script.

This is an extreme edge case and no solution presents itself. A possible workaround is to add an option to disable Flash uploads.

I have passed the information upstream to http://swfupload.org/forum/generaldiscussion/275
and linked back here.

comment:4 lloydbudd6 years ago

  • Milestone 2.5 deleted

comment:5 follow-up: DD326 years ago

Just a note on this for any others who come accross it.

I had the HTTP Error error on windows a short time ago, It turned out to be caused by the plugin "Bad Behaviour" kicking in.

comment:6 in reply to: ↑ 5 Jeffrey046 years ago

Replying to DD32:

Just a note on this for any others who come accross it.

I had the HTTP Error error on windows a short time ago, It turned out to be caused by the plugin "Bad Behaviour" kicking in.

thanks for the temporary solution. So where should we report this problem? report to the badbehavior development team or open another ticket in trac?

comment:7 DD326 years ago

thanks for the temporary solution. So where should we report this problem? report to the badbehavior development team or open another ticket in trac?

Should be reported to the Bad behaviour plugin developer, I never got around to do it, thanks for bring this up :) (report it yourself too :P)

Note: See TracTickets for help on using tickets.