Make WordPress Core

Opened 4 months ago

Closed 4 months ago

#60489 closed enhancement (duplicate)

Enhance User Navigation by Minimizing 'Edit Profile' Redundancy in Admin Bar

Reported by: dionysous's profile dionysous Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Toolbar Keywords:
Focuses: ui, accessibility, ui-copy Cc:

Description

The admin bar dropdown for authenticated users exhibits redundancy in its navigation links. The intent of this ticket is to suggest an improvement to the user interface by altering one of the "Edit Profile" links to a "View Profile" link. This modification promises to streamline the navigation experience by affording users the ability to swiftly access their public profile directly from the admin bar.

WordPress

Current Interface:

  • Clicking on the username in the admin bar's top-right corner navigates to the Edit Profile page.
  • Hovering over the username reveals the dropdown menu, which contains multiple links:
    • "Howdy, ((displayname))" redirects to the Edit Profile page.
    • "((displayname))" also redirects to the Edit Profile page.
    • "Edit Profile" leads to the same Edit Profile page.
    • "Log Out" is the only option that diverges, correctly redirecting to the logout process.

Proposed Interface Enhancement:

  • The username in the admin bar's top-right corner continues to lead to the Edit Profile page.
  • Hovering over the username still displays the dropdown menu, but with an optimized link arrangement:
    • "Howdy, ((displayname))" maintains its redirection to the Edit Profile page.
    • "View Profile" replaces the username link and directs to the View Profile page.
    • "Edit Profile" remains unchanged, leading to the Edit Profile page.
    • "Log Out" continues to facilitate the logout process.

https://i.imgur.com/TE0goDX.png

Meta (wordpress.org)

Current Interface:

  • The username in the admin bar's top-right corner navigates to the Edit Profile page.
  • Hovering over the username reveals the dropdown menu, which includes:
    • "Howdy, ((displayname))" redirects to the Edit Profile page.
    • "((username))" combined with "((displayname))" redirects to the Edit Profile page.
    • "Edit Profile" leads to the same Edit Profile page.
    • "Log Out" diverges, leading to the logout process.

Proposed Interface Enhancement:

  • The username in the admin bar's top-right corner continues to navigate to the Edit Profile page.
  • Hovering over the username still displays the dropdown menu, but with a more intuitive link setup:
    • "Howdy, ((displayname))" maintains its redirection to the Edit Profile page.
    • "((username))" alongside "View Profile" now directs to the View Profile page.
    • "Edit Profile" remains unchanged, leading to the Edit Profile page.
    • "Log Out" continues to facilitate the logout process.

https://i.imgur.com/TE0goDX.png

Challenges:

  • In a standard WordPress installation, it should first be checked whether a public profile is visible. The "View Profile" link should only lead to the public profile if it is indeed visible. Is this possible?
  • On wordpress.org, there is always a publicly visible profile. There, the "View Profile" link should always be present.
  • For example, I often use my profile to check my photo uploads in the directory. Since all three links currently lead to "Edit Profile," one must navigate further from there, which is cumbersome.
  • Changing the dropdown menu could initially lead to slight confusion among the WordPress community. However, this can be prevented with clear link labels.

Discussion

I welcome feedback on this suggestion. Do you also find the current redundancy of "edit profile" links in the admin bar dropdown confusing? I'd love to hear different perspectives on this UX matter.

Change History (6)

This ticket was mentioned in Slack in #design by dionysous. View the logs.


4 months ago

#2 @sabernhardt
4 months ago

  • Component changed from General to Toolbar

Related/duplicate: #43633

This ticket was mentioned in Slack in #meta by dionysous. View the logs.


4 months ago

#4 @dionysous
4 months ago

A related ticket (just for the wordpress.org part) was created: https://meta.trac.wordpress.org/ticket/7462

Edit: I wasn't sure, which wp.org component was affected and where to post this topic. I think GitHub is the right place: https://github.com/WordPress/wporg-mu-plugins/issues/268#issuecomment-1938290193

Last edited 4 months ago by dionysous (previous) (diff)

This ticket was mentioned in Slack in #accessibility by joedolson. View the logs.


4 months ago

#6 @joedolson
4 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for your ticket, @dionysous! While there are some small differences in the solutions you're suggesting compared with the discussion on #43633, this is essentially a duplicate of that issue. By closing this ticket and marking it as a duplicate, there will be a relationship between those, so your information will still be findable.

As a note, the change on meta that you're proposing won't require any changes to core; that's something that can be accomplished without modifying core.

Note: See TracTickets for help on using tickets.