Make WordPress Core

Opened 4 months ago

Closed 4 months ago

#60531 closed defect (bug) (reported-upstream)

TypeError: t.substr is not a function

Reported by: 254volkan's profile 254volkan Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.5
Component: Editor Keywords:
Focuses: Cc:

Description (last modified by sabernhardt)

When adding or editing a navigation block, I get the error above.
https://imgur.com/FQQC5CQ
https://imgur.com/iBYBbxD
https://imgur.com/Fqy8ZJL

Change History (6)

#1 @254volkan
4 months ago

https://i.imgur.com/FQQC5CQ.png
https://i.imgur.com/iBYBbxD.png
https://i.imgur.com/Fqy8ZJL.png

I placed the wrong link in the ticket above.

#2 @swissspidy
4 months ago

  • Severity changed from critical to normal
  • Version set to trunk

#3 @sabernhardt
4 months ago

  • Description modified (diff)

#4 @huzaifaalmesbah
4 months ago

Reproduction Report

I can reproduce this issue on the live server but I can't reproduce it on my local server.

Environment

  • WordPress: 6.5-beta1
  • PHP: 8.1.18
  • Server: LiteSpeed
  • Database: mysqli (Server: 10.3.38-MariaDB-0ubuntu0.20.04.1 / Client: mysqlnd 8.1.18)
  • Browser: Chrome 121.0.0.0
  • OS: macOS
  • Theme: Twenty Twenty-Four 1.0
  • MU Plugins: None activated
  • Plugins:
    • Test Reports 1.1.0

https://i.ibb.co/4ZVMqJF/tt4.png

Version 0, edited 4 months ago by huzaifaalmesbah (next)

#5 @254volkan
4 months ago

The environment I used to replicate the error

Local Wp on Windows

WordPress: 6.5-beta1
PHP: 8.3.0
Server: Nginx
Database: MariaDB 10.4.10
Browser: Brave v1.62.162 , Firefox 123.0b9 (64-bit)
OS: Windows
Theme: Twenty Twenty-Four 1.0
MU Plugins: None activated
Plugins: None

#6 @swissspidy
4 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

Looks like this has been reported upstream in Gutenberg already: https://github.com/WordPress/gutenberg/issues/58987

Note: See TracTickets for help on using tickets.