Make WordPress Core

Opened 2 months ago

Closed 2 months ago

Last modified 2 months ago

#60537 closed defect (bug) (fixed)

Font library: Not all fonts are reflected in the backend

Reported by: nithins53's profile nithins53 Owned by: youknowriad's profile youknowriad
Milestone: 6.5 Priority: normal
Severity: normal Version:
Component: Editor Keywords: has-patch has-unit-tests
Focuses: Cc:

Description

While testing the font library in WordPress 6.5 Beta 1, not all fonts are reflected in the back end once they are applied. But if viewed from the front end the font can be seen properly.

Attachments (2)

Screenshot 2024-02-14 132428.png (568.2 KB) - added by vivekawsm 2 months ago.
Backend
Screenshot 2024-02-14 132531.png (259.5 KB) - added by vivekawsm 2 months ago.
Frontend

Download all attachments as: .zip

Change History (14)

#1 @kafleg
2 months ago

Please create the issue here, https://github.com/WordPress/gutenberg/issues/new/choose

We are also discussing the font library issue here, #60536

#2 @nithins53
2 months ago

The font I tested it with was this onehttps://fonts.google.com/specimen/Are+You+Serious?sort=alpha&query=are+you+serious. One thing I found is that the font is properly reflected if we save the change and visit the editor again. But during the first applications, the font is not reflected on the editor side.

#3 @vivekawsm
2 months ago

Environment

  • WordPress: 6.5-beta1-57631
  • PHP: 8.2.4
  • Server: Apache/2.4.56 (Win64) OpenSSL/1.1.1t PHP/8.2.4
  • Database: mysqli (Server: 10.4.28-MariaDB / Client: mysqlnd 8.2.4)
  • Browser: Chrome 121.0.0.0 (Windows 10/11)
  • Theme: Twenty Twenty-Four 1.0
  • MU-Plugins: None activated

The issue still exists in testing

#4 follow-up: @audrasjb
2 months ago

This issue needs to be reported in the upstream Gutenberg repository: https://github.com/WordPress/gutenberg/issues/new/

Please let us know when the issue is created on GitHub so we can close this ticket as reported-upstream :)

#5 in reply to: ↑ 4 @nithins53
2 months ago

Replying to audrasjb:

This issue needs to be reported in the upstream Gutenberg repository: https://github.com/WordPress/gutenberg/issues/new/

Please let us know when the issue is created on GitHub so we can close this ticket as reported-upstream :)

The issue has been reported there, here's the link: https://github.com/WordPress/gutenberg/issues/59010

#6 @swissspidy
2 months ago

#60541 was marked as a duplicate.

#7 @audrasjb
2 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed

#8 @nithins53
2 months ago

  • Resolution reported-upstream deleted
  • Status changed from closed to reopened

Reopening as a ticket is still needed to add the PR to core https://github.com/WordPress/gutenberg/pull/59019.

Last edited 2 months ago by nithins53 (previous) (diff)

#10 @youknowriad
2 months ago

  • Owner set to youknowriad
  • Resolution set to fixed
  • Status changed from reopened to closed

In 57657:

Editor: Format and sanitize font family names according the CSS spec.

This fixes two bugs in the font library.

  • Fonts using special characters were not being rendered properly in the frontend.
  • Allows the ability to use generic() in font family names.

Props mmaattiiaass, nithins53, kafleg, vivekawsm, swissspidy, audrasjb.
Fixes #60537.

#11 @youknowriad
2 months ago

  • Milestone set to 6.5
Note: See TracTickets for help on using tickets.