Make WordPress Core

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#60539 closed defect (bug) (duplicate)

Styling issue when adding patterns

Reported by: bilalmughl's profile bilalmughl Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.5
Component: Editor Keywords: reporter-feedback
Focuses: Cc:

Description

Bug Report

Description

When attempting to add a new pattern using the Hello Elementor 3.0.1 Theme, a styling issue occurs.

Environment

  • WordPress: 6.5-beta1
  • PHP: 8.0.30-dev
  • Server: PHP.wasm
  • Database: WP_SQLite_Translator (Server: 5.5 / Client: 3.40.1)
  • Browser: Chrome 121.0.0.0
  • OS: Windows 10/11
  • Theme: Hello Elementor 3.0.1
  • MU Plugins:
    • 0-playground.php
    • 0-sqlite.php
    • WordPress WXZ Exporter 0.1
  • Plugins:
    • Create Block Theme 1.13.8
    • Debug Bar 1.1.4
    • Health Check & Troubleshooting 1.7.0
    • Test Reports 1.1.0
    • User Switching 1.7.2
    • WordPress Importer Git loader 0.8.2

Steps to Reproduce

  1. 🐞 Bug occurs. Install and activate the Hello Elementor 3.0.1 Theme. Navigate to the pattern library and try to add a new pattern.

Expected Results

  1. ✅ The new pattern should be added seamlessly without any styling issues, integrating well with the existing layout.

Actual Results

  1. ❌ Styling issues are observed, potentially disrupting the visual presentation of the newly added pattern.

Additional Notes

This problem specifically occurs when utilizing the Hello Elementor 3.0.1 Theme while trying to incorporate a new pattern into the design.

Supplemental Artifacts

Videos:
https://take.ms/DlR9f
https://take.ms/DlR9f

Change History (4)

#1 @swissspidy
3 months ago

  • Focuses ui accessibility css performance removed
  • Keywords reporter-feedback added
  • Severity changed from major to normal
  • Summary changed from Styling issues occur when adding a new pattern using the Hello Elementor 3.0.1 Theme, disrupting the visual presentation of the design. to Missing wp-includes/css/classic-themes.min.css stylesheet
  • Version set to trunk

I just downloaded WordPress 6.5 Beta 1 from https://wordpress.org/news/2024/02/wordpress-6-5-beta-1/ and the wp-includes/css/classic-themes.min.css file definitely does exist. So it might be possible it got not fully copied over when installing the beta.

Have you tried re-installing the 6.5 Beta either manually or via Dashboard -> Updates?

#2 @swissspidy
3 months ago

  • Summary changed from Missing wp-includes/css/classic-themes.min.css stylesheet to Styling issue when adding patterns

Whoops, my bad for confusing this with #60538, the two looked very similar.

This might be an issue specific to Playground because of that missing stylesheet. Does the same happen when you install WordPress 6.5 Beta on a local test environment?

#3 @bilalmughl
3 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

The problem occurred during testing on Playground.

Last edited 3 months ago by bilalmughl (previous) (diff)

#4 @swissspidy
3 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.