Make WordPress Core

Opened 3 months ago

Closed 3 months ago

#60573 closed defect (bug) (worksforme)

no font faces were installed error when i upload a woff2 font

Reported by: wplmillet's profile wplmillet Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.5
Component: Editor Keywords:
Focuses: Cc:

Description

Bug Report

Description

Describe the bug.
Quand je tente de téléverser une police woff2 depuis mon ordi dans la librairie de polices, j'ai l'erreur suivante :

No font faces were installed. Fetch error: <p>There has been a critical error on this website.</p><p><a href="https://wordpress.org/documentation/article/faq-troubleshooting/">Learn more about troubleshooting 
WordPress.</a></p> 

https://i.imgur.com/W8ng06W.png
The font does not appear in the library.
In addition, the error message does not appear correctly as it is displayed in HTML format
Important: This font is correct as I can use it from Manage Theme Fonts in Appearance menu

Environment

  • WordPress: 6.5-beta1-57654
  • PHP: 8.0.30-dev
  • Server: PHP.wasm
  • Database: WP_SQLite_Translator (Server: 5.5 / Client: 3.40.1)
  • Browser: Chrome 121.0.0.0
  • OS: Linux
  • Theme: Twenty Twenty-Four 1.0
  • MU Plugins:
    • 0-playground.php
    • 0-sqlite.php
    • WordPress WXZ Exporter 0.1
  • Plugins:
    • Create Block Theme 1.13.8
    • Debug Bar 1.1.4
    • Health Check & Troubleshooting 1.7.0
    • Test Reports 1.1.0
    • User Switching 1.7.2
    • WordPress Importer Git loader 0.8.2

Steps to Reproduce

  1. 🐞 Bug occurs.

Menu Editor, Styles ( modify styles), typography and Manage Fonts
Then in the new windows, go to Upload , Upload font
Then choose the local font

Expected Results

  1. ✅ What should happen.

I want to upload a personnal local font on my site

Actual Results

  1. ❌ What actually happened.

Just a message :

No font faces were installed. Fetch error: <p>There has been a critical error on this website.</p><p><a href="https://wordpress.org/documentation/article/faq-troubleshooting/">Learn more about troubleshooting 
WordPress.</a></p> 

The message is badly formatted and appears in HTML

Additional Notes

  • Any additional details worth mentioning.

Supplemental Artifacts

Add Inline: https://i.imgur.com/W8ng06W.png
or
Add as Attachment

Change History (7)

#1 @swissspidy
3 months ago

  • Component changed from Media to Editor
  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 6.5
  • Severity changed from major to normal

#2 @costdev
3 months ago

  • Component changed from Editor to Media
  • Keywords needs-patch removed
  • Milestone changed from 6.5 to Awaiting Review
  • Severity changed from normal to major

Hi @wplmillet, thanks for opening this ticket!

Can you enable WP_DEBUG in your site's wp-config.php file? This will reveal some more details for the error.

This line can be used to enable WP_DEBUG:

define( 'WP_DEBUG', true );

You may already have a line that says define( 'WP_DEBUG', false ); - you can just change false to true in that case.

If you can then repeat the steps to produce the error, and drop the more detailed error message here, that would be great!

Version 0, edited 3 months ago by costdev (next)

#3 @costdev
3 months ago

  • Component changed from Media to Editor
  • Keywords needs-patch reporter-feedback added
  • Milestone changed from Awaiting Review to 6.5
  • Severity changed from major to normal

#4 @wplmillet
3 months ago

  • Component changed from Editor to Media
  • Keywords needs-patch reporter-feedback removed
  • Severity changed from normal to major

I'm on playground . So what is the method to retrieve the log ?
In an other test, i see that :
if I go back to the font library upload tab, the font appears in the list under library but not in the list in the side column.
https://i.imgur.com/mUBHCIL.png

This ticket was mentioned in Slack in #core by rajinsharwar. View the logs.


3 months ago

#6 @swissspidy
3 months ago

  • Component changed from Media to Editor

#7 @swissspidy
3 months ago

  • Milestone 6.5 deleted
  • Resolution set to worksforme
  • Severity changed from major to normal
  • Status changed from new to closed

I don't think Playground allows accessing the logs.

This looks more like a Playground issue than an issue in the font library itself. I cannot reproduce this locally on a development site nor with wp-now (which uses Playground under the hood).

Therefore I'm closing this issue.

if I go back to the font library upload tab, the font appears in the list under library but not in the list in the side column.

It will only show up once you activate the font. In your screenshot, 0/2 variants are active

Note: See TracTickets for help on using tickets.