Make WordPress Core

Opened 8 weeks ago

Closed 8 weeks ago

#60584 closed defect (bug) (duplicate)

Pagination URLs don't work when previewing scheduled posts

Reported by: ishiiyoshinori's profile ishiiyoshinori Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Posts, Post Types Keywords: has-patch
Focuses: Cc:

Description

When previewing a scheduled post that includes <!--nextpage-->, the URLs returned by wp_link_pages() are incorrect.

Expected second page URL:
https://example.com/?p=12345&page=2&preview=true

The URL of the second page returned by wp_link_pages():
https://example.com/?p=12345%2F2&preview=true

I found the same bug report in ticket #32295, which was created 9 years ago, so please check the updated patch for the latest trunk.

Attachments (1)

post-template.php.patch (836 bytes) - added by ishiiyoshinori 8 weeks ago.

Download all attachments as: .zip

Change History (2)

#1 @swissspidy
8 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version trunk deleted

Duplicate of #32295.

Hi there and welcome to WordPress Trac!

Since this appears to be a duplicate, I am closing this ticket as such. Let's focus the discussion and testing on just one ticket.

Note: See TracTickets for help on using tickets.