Make WordPress Core

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#60588 closed defect (bug) (duplicate)

incompatible archive error

Reported by: klaudisio's profile klaudisio Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.4.3
Component: Plugins Keywords:
Focuses: Cc:

Description

I keep getting this when I try to upload ANY plugin. I can not find a work around and I need to upload a couple of plugins to finish my wordpress website.

PLEASE HELP!

Change History (20)

#1 @costdev
3 months ago

  • Keywords reporter-feedback added

Hi @klaudisio, welcome to Trac!

Can you confirm what version of WordPress you're using?

#2 @klaudisio
3 months ago

6.4.3
I can't upload ANY plugins at all whether its on safari or chrome

#3 @costdev
3 months ago

Thanks for confirming @klaudisio!

We've been tracking this issue in #60398. A fix has been committed to trunk and will be released in WordPress 6.5. We may release a new version of WordPress 6.4.x, but that hasn't been decided yet.

In the meantime, you can install this plugin from the above mentioned ticket, written by a WordPress Core developer, that should resolve your issue: https://core.trac.wordpress.org/raw-attachment/ticket/60398/force-pclzip-0.1.zip (it should upload just fine)

Let us know if that resolves the issue for you. 🙂

Last edited 3 months ago by costdev (previous) (diff)

#4 @klaudisio
3 months ago

that did not download, said it didn't exist, can you please send it again?

#5 @klaudisio
3 months ago

can you send zip file to my email?
XXXXXXX?

edit: Removing email from public bug tracker

Last edited 3 months ago by jorbin (previous) (diff)

#7 @klaudisio
3 months ago

still won't allow me to upload the plugin. NO plugin can be uploaded

#8 @klaudisio
3 months ago

still did not work

#9 @costdev
3 months ago

Did you download the file using Safari or Chrome? Safari can repackage the ZIP file and result in a ZIP that cannot be uploaded, so try downloading the ZIP file in Chrome if you didn't already.

#10 @klaudisio
3 months ago

didn't work on chrome

#11 @klaudisio
3 months ago

do you know when the bug is going to be fixed? Is this happening to everyone?

#12 @costdev
3 months ago

If you have access to the files on your website:

  1. Create a force-pclzip.php file in the wp-content/plugins/ directory.
  2. Add the following to the file:
<?php

/**
 * Plugin Name: Force PclZip.
 */

// If this file is called directly, abort.
if ( ! defined( 'WPINC' ) ) {
        die;
}

add_filter( 'unzip_file_use_ziparchive', '__return_false' );
  1. Save the file.
  2. Navigate to Plugins > Installed plugins.
  3. Click Activate for the Force PclZip plugin.
  4. Try uploading one of the plugins that weren't working for you.

#13 @klaudisio
3 months ago

oh boy, this is too hard for me to understand. I'm not really a coder, I;m using Brizy to design my website
I tried Elementor but it never really worked for me and was very difficult to understand. I understand a little about WP but not all the code.

#14 @jorbin
3 months ago

Hi @klaudisio Are you zipping up the plugins yourself using a UI such as finder? If so, that will trigger the issue. I would suggest zipping via the command line.

#15 @klaudisio
3 months ago

I right-click on my mac and select compress. what is the other option? How do I do that?

#16 @jorbin
3 months ago

On a mac, you can use the command line, and a command zip -r file.zip folder_to_zip to create a zip.

If you are trying to download a zip file using safari, there are instructions in https://core.trac.wordpress.org/ticket/60398#comment:41 for how to have it not unzip it for you so you would need to zip it yourself.

#17 @klaudisio
3 months ago

let me try this stand by

#18 @klaudisio
3 months ago

IT WORKED!!! I UNCHECKED THE BOX IN SAFARI AND THAT ALLOWED ME TO UPLOAD THE PLUGINS. THANK YOU ALL SO MUCH FOR HELPING ME!

THANK YOU , THANK YOU , THANK YOU!!!

:)

#19 @costdev
3 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version set to 6.4.3

Duplicate of #60398.

Thanks @jorbin! You're welcome @klaudisio!

Let's close this ticket as a duplicate of the tracking ticket.

#20 @klaudisio
3 months ago

GREAT THANK YOU! Hopefully this will get fixed but now I know about unchecking that box in safari which I NEVER knew about so again, thank you!

Note: See TracTickets for help on using tickets.