Make WordPress Core

Opened 3 months ago

Closed 2 months ago

#60612 closed defect (bug) (worksforme)

Twenty Fifteen: mobile menu unresponsive in 3.6

Reported by: perbovbjerg's profile perbovbjerg Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.4.3
Component: Bundled Theme Keywords: reporter-feedback close
Focuses: Cc:

Description

Hi. I am using the Twenty Fifteen theme at my personal homepage that can be found at https://perbovbjerg.dk
When using the 3.6 version of the theme the mobile menu is unresponsive on my phone and tablet. It works fine enough when I simulate a phone or tablet in my browser. But as I rollback to version 3.5 everything works just fine

Change History (6)

#1 @poena
3 months ago

  • Component changed from Themes to Bundled Theme
  • Severity changed from major to normal

#2 @sabernhardt
3 months ago

  • Keywords reporter-feedback added
  • Summary changed from Theme Twenty Fifteen 3.6 to Twenty Fifteen: mobile menu unresponsive in 3.6

Hi and welcome to WordPress Trac!

By "unresponsive," do you mean that tapping the menu button did not expand the menu when you tried the newer version of the theme? Or did the menu display differently on smaller screens?

Version 3.6 changed the way the theme's JavaScript printed, and functions.js moved from the footer to the head. I noticed you use WP Fastest Cache; could the cache have printed the script twice or else removed it entirely?

#3 @poena
3 months ago

Hi
I set up a test site and the primary menu and its submenu items work for me. But I can only test on my android phone using Chrome, Firefox and Edge. Perhaps it is related to caching as mentioned above.

Can you add any more details? Such as what type of phone and tablet and which browsers you are using.

#4 @karmatosed
2 months ago

  • Keywords close added

I also seem unable to reproduce this. I am going to cautiously add the keyword 'close' for now and we can always review this should we get more information.

#5 @sabernhardt
2 months ago

@perbovbjerg
I noticed that twentyfifteen-script-js is in the head now for your site, and the menu seems to expand properly there. Did purging the cache help, or did you find another way to fix the issue you had with Twenty Fifteen 3.6?

#6 @karmatosed
2 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

For now I am going to close this, in particular with the information that @sabernhardt just added and the fact I am unable to reproduce this. We can always reopen of have a new ticket, thank you everyone.

Note: See TracTickets for help on using tickets.