Make WordPress Core

Opened 3 months ago

Closed 2 months ago

Last modified 2 months ago

#60616 closed defect (bug) (reported-upstream)

Twenty Twenty-Four: There is shaking effect while selecting Maelstrom style

Reported by: krupajnanda's profile krupajnanda Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.4.3
Component: Bundled Theme Keywords: has-testing-info has-screenshots
Focuses: ui, accessibility Cc:

Description

When I select the Maelstrom style it continuously gives a shaking effect. Is this given purposely as its name suggests? 🤔

Bug Report

Description

I observed the constant shaking effect for Maelstrom style.

Environment

  • WordPress: 6.4.3
  • PHP: 8.0.30-dev
  • Server: PHP.wasm
  • Database: WP_SQLite_Translator (Server: 5.5 / Client: 3.40.1)
  • Browser: Chrome 121.0.0.0
  • OS: macOS
  • Theme: Twenty Twenty-Four 1.0
  • MU Plugins:
    • 0-playground.php
    • 0-sqlite.php
    • WordPress WXZ Exporter 0.1
  • Plugins:
    • Create Block Theme 1.13.8
    • Debug Bar 1.1.4
    • Health Check & Troubleshooting 1.7.0
    • Test Reports 1.1.0
    • User Switching 1.7.3
    • WordPress Importer Git loader 0.8.2

Steps to Reproduce

  1. Go to Themes > Editor
  2. Now, open a style
  3. Click on Browse Style
  4. Select Maelstrom style
  5. Now, observe the shaking effect as shown in the screenshot.

Expected Results

  1. If we select any other styles they don't behave strangely whereas here it seems like a bug. But not sure if such an effect is given purposely.

Actual Results

  1. ❌ It should not shake like other styles.

Supplemental Artifacts

Add as Attachments

Attachments (1)

shaking effect with Maelstrom style.mov (9.0 MB) - added by krupajnanda 3 months ago.

Change History (9)

#1 @poena
3 months ago

  • Component changed from Editor to Bundled Theme
  • Severity changed from minor to normal

#2 @poena
3 months ago

  • Summary changed from There is shaking effect while selecting Maelstrom style to Twenty Twenty-Four: There is shaking effect while selecting Maelstrom style

#3 @poena
3 months ago

Hi @krupajnanda
Thank you for the report.
This type of shaking is not intentional.

I have not been able to reproduce it on a local install of 6.4.3 or 6.5 beta 2,
nor on the WordPress playground, with or without the mentioned plugins.

I am using macOS, Chrome Version 121.0.6167.184
My screen resolution is 1512x982.
Reducing the browser window size does not make a difference.

#4 @huzaifaalmesbah
2 months ago

I was unable to replicate the issue on both local and live servers on both 6.5-RC1 and 6.4.3 versions using macOS and Windows.

This ticket was mentioned in Slack in #accessibility by joedolson. View the logs.


2 months ago

#6 @rcreators
2 months ago

As discussion on accessibility bug scrub today. We found the issue. When we change the style, page recalculate the hight and add scrollbar to it. For some styles, it gets removed and for some it removes but blank area stays. For reference check the this link: http://somup.com/cZeqoHC6mn

The scrollbar needs to be removed for all the styles.

#7 @joedolson
2 months ago

Noting that the issue is specific to the 'Browse Styles' functionality (findable from the right sidebar 'Styles' option > 'Browse Styles', and *not* in the Styles selection panel in the left sidebar. Most likely this is specific to the Zoom out mode.

#8 @sabernhardt
2 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed
Version 0, edited 2 months ago by sabernhardt (next)
Note: See TracTickets for help on using tickets.