Make WordPress Core

Opened 8 weeks ago

Closed 7 weeks ago

#60623 closed defect (bug) (reported-upstream)

Richtext : "multiline=p" property is not working in latest WP version

Reported by: kushang78's profile kushang78 Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.4.3
Component: Editor Keywords:
Focuses: Cc:

Description

Issue:

I'm facing issues with the Richtext component When I'm used "multiline=p" property in latest WP version - 6.4.3.

The scenario I've:

I've one custom GB slider block that includes some Richtext for contents, Gallery for images and links as multi-level functionality.

Multi-level functionality:
On click of Plus Button, The slider will increase by one with all the empty/placeholder contents & components.
On click of Minus/Remove Button, The current active slider will remove completely.

After updating WP to the latest version the "multiline=p" property not working properly. I don't know why this is happened. But, I've many posts to depends on the "multiline=p" property, Because using this property, The contents of the slider's automatically converted all the copied heading tags & List items into different paragraph tags. But, Now in latest WP version, When I added copied contents, It's throw the content like [object Object].

In other hand, I've some document files ready for this slider's content so I just copied all the contents from that document file and added here in this block.

The Error:

WP says please use Innerblocks instead of Richtext property "multiline=p". Please check the attached file for this deprecated error.

The Code Example:

<RichText
	tagName="p"
	placeholder={__('Heading', 'mysite')}
	value={heading}
	onChange={heading => setAttributes({ heading })}
	multiline="p"
/>

The Solution I tried:

I tried and used the Innerblocks for this, And It's not working properly for my custom slider block as before.

So, If anyone have solutions/feedbacks/suggestions for this, Please let me know.

Thanks!

Attachments (1)

Screenshot 2024-02-23 at 3.49.06 PM.png (36.7 KB) - added by kushang78 8 weeks ago.

Download all attachments as: .zip

Change History (5)

#1 @swissspidy
8 weeks ago

Tickets related to the Gutenberg Editor should be filed on the Gutenberg GitHub Repository

Would you mind creating this ticket over there instead?

#2 @wildworks
8 weeks ago

This is probably the issue filed on Gutenberg GitHub Repository: https://github.com/WordPress/gutenberg/issues/59318

#3 @kushang78
7 weeks ago

Ticket created successfully on Gutenberg GitHub Repo as well.

Ticket URL: https://github.com/WordPress/gutenberg/issues/59318

#4 @swissspidy
7 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.