Make WordPress Core

Opened 5 months ago

Closed 5 months ago

#60634 closed defect (bug) (worksforme)

Background color styling of numbered list block differs between frontend and editor

Reported by: harshalkadu's profile harshalkadu Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.5
Component: Editor Keywords: has-testing-info needs-testing
Focuses: Cc:

Description

BE > list block > selected background color are not getting applied for numbering style in the backend, but in FE they are.

BE SS: https://prnt.sc/4CTqSE66J4wM
FE SS: https://prnt.sc/BHnpNi8QLRJ9

Steps to reproduce:

  1. Add or edit a new or old post
  2. Add a list block.
  3. Add list items 3–4.
  4. Add numbering style, i.e., numbers.
  5. Go to styles > colour > apply background colour.
  6. Observe that background colours are not applied for number styles.
  7. Update the post and check the same in FE. It's getting applied in FE for number styles.

### Environment

  • WordPress: 6.5-beta2-57691
  • PHP: 8.1.23
  • Theme: Twenty Twenty-Four 1.0

Change History (9)

#1 @poena
5 months ago

Hi @harshalkadu Thank you for the report. Kindly avoid using custom abbreviations like BE and FE. It makes the report more difficult to read.

Does this problem happen in other themes?

#2 @harshalkadu
5 months ago

Hi @poena
Thank you for your feedback. I'll refrain from using custom abbreviations like BE and FE in future reports to ensure clarity and ease of reading. Regarding your question, I have investigated if this issue occurs in other themes as well and found that yes, it's happening in other themes as well.

Tested themes:
Twenty Twenty-Four
Twenty Fourteen

#3 @swissspidy
5 months ago

  • Component changed from General to Editor
  • Summary changed from BE > list block > selected background colour are not getting applied for numbering style in the backend, but in FE they are. to Background color styling of numbered list block differs between frontend and editor

Is this an issue specifically with WordPress 6.5 or is it happening in older versions as well?

#4 @harshalkadu
5 months ago

Hi @swissspidy ,

This issue is specific to WordPress version 6.5, not happening in older versions 6.4.3.

SS: https://prnt.sc/gA_s9XLogEgm

#5 @swissspidy
5 months ago

  • Version set to trunk

#6 @poena
5 months ago

I am not able to reproduce this. Can you please test without plugins active? I noticed some plugins like JetPack in the screenshots.

#7 @poena
5 months ago

  • Keywords needs-testing added

#8 @harshalkadu
5 months ago

Hi @poena ,

I have disabled all other plugins, including JetPack, and tested the functionality again and found that it's working fine now. Confirmed that it's not related to core version 6.5 upgrades.

SS:
https://prnt.sc/2TXUPh9ovF0Y

#9 @swissspidy
5 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Thanks for testing!

In that case I am closing this as it's not an issue in core.

Note: See TracTickets for help on using tickets.