Make WordPress Core

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#60642 closed enhancement (duplicate)

Improvement request: user deletion/merging

Reported by: rcroman's profile rcroman Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.4.3
Component: Users Keywords:
Focuses: Cc:

Description

I'd like to request an improvement to the existing "delete user" function. Currently, this function nicely allows a user account to be deleted with the option of merging the information associated with the account to another user account. This comes in handy when a user creates an account with an incorrect email address, then creates a second account with the correct email address, but there are details associated with the first account (e.g., WooCommerce orders) that need to be transferred to the second account.

The issue is that this function currently relies on a drop-down menu to select the destination account for the merge. My site has over 23,000 users. This drop-down menu thus either takes a very long time to populate, and then a very long time to find and select the correct destination account, or else it crashes the browser on a less well-endowed machine.

Please change this function such that it does not use a fully-populated drop-down menu to make this selection. Use a different mechanism to search for the destination account for the merge. Also, please allow for searching for the destination account either by username or email address. Currently it only allows searching by username.

Change History (2)

#1 @swissspidy
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi there, welcome to WordPress Trac and thanks a lot for your report!

We're already tracking this enhancement to the dropdown in #19867. Please subscribe there for any updates.

#2 @rcroman
3 months ago

Great... thanks!

Note: See TracTickets for help on using tickets.