Make WordPress Core

Opened 7 weeks ago

Last modified 7 weeks ago

#60662 new defect (bug)

WordPress 6.5-beta3-57738 - Full Site Editor breaks after installing "Contact Form 7"

Reported by: capstonebpo's profile capstonebpo Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 6.5
Component: Editor Keywords: reporter-feedback
Focuses: Cc:

Description

Hi- I am using WordPress 6.5-beta3-57738 running Twenty Twenty-Four CHILD theme.

I ran into an issue after installing Contact Form 7 plugin where the site editor breaks as shown in the attached images.

BEFORE-INSTALLING-CONTACT-FORM-7-PLUGIN

https://emailmarketing.capstonebpo.com/wp-content/uploads/2024/02/before-installing-contact-form-7.jpg

AFTER-INSTALLING-CONTACT-FORM-7-PLUGIN

https://emailmarketing.capstonebpo.com/wp-content/uploads/2024/02/after-installing-contact-form-7.jpg

Rajesh

Attachments (2)

before-installing-contact-form-7.jpg (213.8 KB) - added by capstonebpo 7 weeks ago.
after-installing-contact-form-7.jpg (180.9 KB) - added by capstonebpo 7 weeks ago.

Download all attachments as: .zip

Change History (8)

#1 @poena
7 weeks ago

  • Component changed from Plugins to Editor
  • Keywords reporter-feedback added
  • Severity changed from critical to normal

Hi @capstonebpo
Thank you for the report.

I am not able to reproduce this problem.
Perhaps it is related to something you have added to your custom form settings.

Can you include any more information? It is difficult for others to troubleshoot this issue and determine if it is a problem with WordPress or with the plugin.

Are there any error messages in the editor?
Do you know how to check if there any JavaScript warnings or errors in the browser console?

If you are able to install and activate the test reports plugin
https://wordpress.org/plugins/test-reports/
It can help you gather some more details that will help with troubleshooting.

Because this happens with Contact Form 7 installed, it is important that you notify the developer of that plugin, for example through the plugin support forum.

#2 @poena
7 weeks ago

I also want to double check if you meant the block editor, where you edit page content, or the Site Editor. Because the title says Site Editor but the screenshots are of the block editor.
Lets make sure that we are testing the correct thing.

#3 @capstonebpo
7 weeks ago

It's the block editor.

I have a plugin https://wordpress.org/plugins/custom-css-js/ installed to add some styling css to the wpcf7 class to style my form.

#4 @capstonebpo
7 weeks ago

I just rechecked and if I edit a Page via Appearance->Editor->Pages https://emailmarketing.capstonebpo.com/wp-admin/site-editor.php?postType=page&postId=2 it looks fine BUT

when I access "Pages" from the WP admin sidebar and click on any page, it looks like the "after-installing-contact-form-7.jpg"

#6 @poena
7 weeks ago

Kindly respond to the questions above:
Are there any error messages in the editor?

Do you know how to check if there any JavaScript warnings or errors in the browser console?

If you are able to install and activate the test reports plugin
https://wordpress.org/plugins/test-reports/
It can help you gather some more details that will help with troubleshooting.

More information is needed to confirm that if this is a bug with WordPress, or a support question regarding the plugins.

You can find more information about troubleshooting in this article:
https://wordpress.org/documentation/article/faq-troubleshooting/

Note: See TracTickets for help on using tickets.