Make WordPress Core

Opened 3 months ago

Closed 3 weeks ago

#60680 closed defect (bug) (worksforme)

Site's broken

Reported by: rsalafy's profile rsalafy Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: WordPress.org Site Keywords:
Focuses: Cc:

Description

I think wordpress.org is broken when opened with firefox desktop. See attached video.

Attachments (3)

output.mp4 (5.1 MB) - added by rsalafy 3 months ago.
windows-11-and-firefox-123.0.mp4 (5.6 MB) - added by wildworks 3 months ago.
Testing on Windows 11 OS, Firefox browser version 123.0
Ubuntu-22.04-Firefox-123.0.mp4 (6.6 MB) - added by voboghure 3 months ago.
Ubuntu 22.04 / Firefox 123.0 (64-bit)

Change History (8)

@rsalafy
3 months ago

#1 @wildworks
3 months ago

Thanks for the report. I tested it in the following environment, but could not reproduce it.

  • OS: Windows 11
  • Browser: Firefox 123.0 (64-bit)

@wildworks
3 months ago

Testing on Windows 11 OS, Firefox browser version 123.0

#2 @voboghure
3 months ago

Hi @rsalafy
Thanks for the report. I just tested and was unable to reproduce the issue.
I am using the following environment,

  • OS: Ubuntu 22.04
  • Browser: Firefox 123.0 (64-bit)

@voboghure
3 months ago

Ubuntu 22.04 / Firefox 123.0 (64-bit)

#3 @sabernhardt
7 weeks ago

@rsalafy Have you experienced the overlap again? I think this might have been fixed soon after you had the problem.

I do not find an issue in Firefox 124.0.2 and Windows 10, but that is not the same as your environment.

#4 @sabernhardt
7 weeks ago

The video "output.mp4" shows a visit to https://developer.wordpress.org/apis/wp-config-php/#moving-plugin-folder

As page loads:

  • The viewport is wide.
  • The header contains the WordPress global header and the WordPress Developer Resources header.
  • Under the Search Resources search form, there is a large empty space.
  • The heading and first paragraph are not visible yet.
  • The Chapters list and the "In this article" box both appear on the right half of the screen.

Scrolling down:

  • The global header disappears, but the WordPress Developer Resources header is fixed at the top. The W logo drops down (or stays) in the top left corner. The "wp-config.php" page heading moved into the fixed header next to "WordPress Developer Resources."
  • The first few paragraphs appear, positioned from the left edge of the page content area.
  • The Chapters list is also positioned on the left side, in front of the article information.
  • The "In this article" box remains fixed on the right side, and the article content does not extend that far (the article text covers about three fourths and then the side navigation is about one-fourth).

In my experience, the page has three columns as it loads: a Chapters list, the article content, and the "In this article" box. The columns remain that way when scrolling down, and the left and right side columns stay fixed in place.

I was able to achieve a different type of overlap in Chrome by scrolling down, disabling JavaScript without refreshing, and scrolling back up. However, a script failure likely was not the cause (at least not on its own) since the article content was in the middle, between the fixed columns. For another possibility, I think that the .is-layout-* classes might have failed to work properly at that time.

Last edited 7 weeks ago by sabernhardt (previous) (diff)

#5 @sabernhardt
3 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Severity changed from critical to normal
  • Status changed from new to closed

Because no one reproduced the error, I'll close this. If this problem (or something similar) occurs in the Developer Hub, please open a ticket on Meta Trac, and add a link to it from this ticket.
https://meta.trac.wordpress.org/newticket

Note: See TracTickets for help on using tickets.