Make WordPress Core

Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#60738 closed defect (bug) (duplicate)

WordPress installation page '/wp-admin/setup-config.php' shows 404 link

Reported by: fanly's profile fanly Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Upgrade/Install Keywords: has-patch
Focuses: docs Cc:

Description

File location: /wp-admin/setup-config.php
Problem description: 404 dead link in file https://wordpress.org/documentation/article/editing-wp-config-php/

<?php
                printf(
                        /* translators: 1: Documentation URL, 2: wp-config.php */
                        __( 'Need more help? <a href="%1$s">Read the support article on %2$s</a>.' ),
                        __( 'https://wordpress.org/documentation/article/editing-wp-config-php/' ),
                        '<code>wp-config.php</code>'
                );

Attachments (3)

404link.png (22.1 KB) - added by fanly 4 months ago.
cn 404 link.png (37.6 KB) - added by fanly 4 months ago.
The Chinese version also has an incorrect 404 link
60738.patch (1020 bytes) - added by shailu25 4 months ago.
Patch Added

Download all attachments as: .zip

Change History (8)

@fanly
4 months ago

@fanly
4 months ago

The Chinese version also has an incorrect 404 link

#1 @SergeyBiryukov
4 months ago

  • Component changed from General to Upgrade/Install
  • Milestone changed from Awaiting Review to 6.6

Hi there, welcome to WordPress Trac! Thanks for the ticket.

Related: #60732, #60736.

@shailu25
4 months ago

Patch Added

#2 @shailu25
4 months ago

  • Keywords has-patch added; changes-requested removed

#3 follow-up: @audrasjb
4 months ago

  • Milestone 6.6 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hello,
Thanks for the ticket and patch! However it is a duplicate of #60732 and the issue has already been partially fixed in [57793]. Some new commit are scheduled as part of #60732 and already have a patch :)

Thanks, closing as duplicate.

Version 0, edited 4 months ago by audrasjb (next)

#4 @SergeyBiryukov
4 months ago

In 57798:

Docs: Update the link to the “Editing wp-config.php” article in wp-load.php.

Follow-up to [57793].

Props fanly, shailu25.
See #60738, #60732.

#5 in reply to: ↑ 3 @SergeyBiryukov
4 months ago

Replying to audrasjb:

However it is a duplicate of #60732 and the issue has already been partially fixed in [57793].

True, though I would say a broken link is a worse experience than just an extra redirect, so this should probably be brought to the attention of the Documentation team to make sure all the redirects are properly created.

Alternatively, these link updates could probably be merged to the 6.5 branch to avoid further reports.

Note: See TracTickets for help on using tickets.