Make WordPress Core

Opened 3 months ago

Closed 7 days ago

#60765 closed defect (bug) (duplicate)

Typography Presets

Reported by: ramonopoly's profile ramonopoly Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.5
Component: Editor Keywords: has-patch has-unit-tests gutenberg-merge
Focuses: Cc:

Description

We should pass theme.json settings to global preset or style value-generating callbacks.

Currently value_func callable properties in PRESETS_METADATA do not have access to the current theme JSON settings.

An example:

wp_get_typography_font_size_value() needs to know other theme.json settings in order to correctly output values.

Styles generated by WP_Theme_JSON::get_stylesheet outside a WordPress instance, using custom settings will therefore have no effect.

See bug issue for further details: https://github.com/WordPress/gutenberg/issues/58135

This ticket is to sync the following Gutenberg PR: https://github.com/WordPress/gutenberg/pull/58362

Change History (3)

This ticket was mentioned in PR #6266 on WordPress/wordpress-develop by @ramonopoly.


3 months ago
#1

Work in progress, please come back later 😄

Trac ticket: https://core.trac.wordpress.org/ticket/60765

#3 @ramonopoly
7 days ago

  • Milestone 6.6 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #61118.

Note: See TracTickets for help on using tickets.