Make WordPress Core

Opened 2 months ago

Closed 2 months ago

#60792 closed enhancement (duplicate)

Do not require WP_ALLOW_MULTISITE to see network tab

Reported by: bennimack's profile bennimack Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: close
Focuses: multisite Cc:

Description

Setting up the Multisite feature is quite difficult. One of the hurdles people
come across when using Multisite is that they first need to set
WP_ALLOW_MULTISITE in their wp-config.php, then they see the Network tab in the Tools section, then they can create a network (see https://developer.wordpress.org/advanced-administration/multisite/create-network/#step-2-allow-multisite).

This is very hidden and in order to make this feature more prominent, I propose to consider removing this flag directly, and always show the network tab.

Attachments (2)

multisite_flag.patch (2.5 KB) - added by bennimack 2 months ago.
patch file
multisite_flag2.patch (2.3 KB) - added by bennimack 2 months ago.
Variant 2 - the PHP constant is not mandatory anymore, but if actively set to "false" the network tab is not shown anymore

Download all attachments as: .zip

Change History (7)

@bennimack
2 months ago

patch file

@bennimack
2 months ago

Variant 2 - the PHP constant is not mandatory anymore, but if actively set to "false" the network tab is not shown anymore

#1 @bennimack
2 months ago

I added a second variant for discussion:

  • Patch #1 actually avoids checking for the constant WP_ALLOW_MULTISITE at all, and shows the network tab in order to migrate to MultiSite for anyone.
  • Patch #2 behaves the same way, except for the possibility to have people explicitly set define('WP_ALLOW_MULTISITE', false) in their wp-config.php. If explicitly disabled, the network tab will not show up.

#2 @tobifjellner
2 months ago

An overwhelming majority of all WordPress are single installs that never will be converted to network installations.

I'd really prefer not having hundreds of support topics where someone accidentally turned their site into a network because they needed to publish more than one page.

But perhaps some official/community guide plugin could make the transition easier, perhaps visible under the tools menu.

#3 @johnbillion
2 months ago

  • Keywords close added
  • Version trunk deleted

Thank you for the ticket @bennimack and welcome!

I thought there had been some recent discussion on this topic, but I can only find #31007 and the comment thread on #32285. Feel free to read through those tickets, but this is an intentional hurdle because administering a Multisite installation requires a certain amount of technical knowledge.

I don't believe anything has changed in this regard in the meantime, so this isn't something that should change.

#4 @bennimack
2 months ago

Thanks for digging into the other issues - really helpful to me.

Just to give some feedback around this topic / issue:

We've been working in a task force of 12 people during CloudFest Hackathon 2024 on this topic with more areas revolving around the Site and Network module in order to make it easier to understand for non-coders, and we considered this one a "low-hanging fruit" as a first, but I understand your reasoning - and it looks like the (valid) reasons haven't changed in the past 9 years.

I hope I can share with you the presentation and the next steps on this in the next few days.

#5 @peterwilsoncc
2 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

@bennimack Thanks for your understanding, intentionally adding friction to a feature is always a complicated decision and your openness to accept the earlier reasoning is appreciated.

I'll close this ticket off as a duplicate of #31007.

Note: See TracTickets for help on using tickets.