Make WordPress Core

Opened 3 months ago

Closed 3 months ago

#60811 closed enhancement (duplicate)

Image Alt text isn't saved when adding from the editor

Reported by: faguni22's profile faguni22 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords:
Focuses: ui, accessibility Cc:

Description

When add Image block in the editor, adding ALT text panel appears in right sidebar. And after adding the ALT text, if you save and want to use the image again in a different place from Media Library, you will see that the ALT text space is blank. You have to add again.

SS: https://d.pr/v/fCXrY4

Change History (3)

#1 @swissspidy
3 months ago

  • Component changed from Media to Editor
  • Type changed from defect (bug) to enhancement

The alt text field in the image block is "local", which means you can have different alt text for different instances of the image throughout your website, depending on the context. It's on purpose that the alt text doesn't sync back to the media library in the way you describe it. That said, when you change the alt text "globally" in the media library, the next time you insert the image somewhere, it will use that alt text by default.

There might be ways to improve that while still supporting all existing workflows. I suggest opening an issue at https://github.com/WordPress/gutenberg since this is a proposed change to the image block, which is developed there.

#2 @audrasjb
3 months ago

  • Focuses accessibility added
  • Keywords 2nd-opinion close added; needs-patch removed
  • Version 6.4.3 deleted

Hello and welcome to WordPress Core Trac!

Adding accessibility focus and close as wontfix suggestion given this it the way it should work: the alternative text of an image should never be defined globally but rather independently on each occurrence, since this alt text could be different for each occurence of the image.

Sometimes, an image can be illustrative (empty alt text needed) and sometimes it can convey a meaning (descriptive alt text needed).

Also, the meaning can of course be different depending on the context.

For instance, when the image is directly wrapped by a link, the alt text must describe the target of the link, not the image.

To summarize, this is done on purpose, for the sake of accessibility.

Last edited 3 months ago by audrasjb (previous) (diff)

#3 @sabernhardt
3 months ago

  • Keywords 2nd-opinion close removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a duplicate of #47456.

It could be worth reopening GB8941 to improve the interface for Image and Gallery blocks.

Note: See TracTickets for help on using tickets.