Make WordPress Core

Opened 4 months ago

Closed 4 months ago

#60819 closed defect (bug) (fixed)

Update the Google fonts JSON data URL to the latest version.

Reported by: mmaattiiaass's profile mmaattiiaass Owned by: swissspidy's profile swissspidy
Milestone: 6.5 Priority: normal
Severity: normal Version:
Component: Editor Keywords: has-patch commit fixed-major dev-reviewed
Focuses: Cc:

Description

Update the Google Fonts JSON data URL to the latest deployed version in the WordPress.org CDN.

Reference:
https://meta.trac.wordpress.org/ticket/7522
https://github.com/WordPress/google-fonts-to-wordpress-collection/pull/21

Change History (13)

This ticket was mentioned in PR #6300 on WordPress/wordpress-develop by @mmaattiiaass.


4 months ago
#1

  • Keywords has-patch added

## What ?

Update the Google Fonts JSON data URL to the latest deployed version in the WordPress.org CDN.

Reference:
https://meta.trac.wordpress.org/ticket/7522
https://github.com/WordPress/google-fonts-to-wordpress-collection/pull/21

---

Trac ticket: https://core.trac.wordpress.org/ticket/60819

#2 @mikachan
4 months ago

  • Milestone changed from Awaiting Review to 6.5

#3 follow-up: @swissspidy
4 months ago

  • Keywords commit dev-feedback added

Why is this change done so late in the cycle? Seems like this could have been done before RC 1.

#4 in reply to: ↑ 3 @mmaattiiaass
4 months ago

Replying to swissspidy:

Why is this change done so late in the cycle? Seems like this could have been done before RC 1.

I think it is because this URL change doesn't add logic or functional change, so from my point of view, the risk is very low. It only removes some data from the JSON file that no is longer needed after #60509.

#5 @swissspidy
4 months ago

That is still not a reason for changing it only right before release instead of before RC.

#6 @mmaattiiaass
4 months ago

There's no functional change, so if the change is not allowed to land, it's fine too.

#7 @huzaifaalmesbah
4 months ago

The only noticeable alteration is the URL change, with all other aspects remaining unchanged.

#8 @swissspidy
4 months ago

  • Component changed from General to Editor

#9 @swissspidy
4 months ago

  • Owner set to swissspidy
  • Resolution set to fixed
  • Status changed from new to closed

In 57871:

Editor: Update the Google Fonts font collection URL to the latest version for 6.5.

Props mmaattiiaass.
Fixes #60819.

#11 @swissspidy
4 months ago

  • Keywords fixed-major added
  • Resolution fixed deleted
  • Status changed from closed to reopened

#12 @peterwilsoncc
4 months ago

  • Keywords dev-reviewed added; dev-feedback removed

[57871] approved for backport. I've confirmed new URL provides and expected response. The removal of the categories from the JSON response has no effect on the UI.

#13 @swissspidy
4 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 57875:

Editor: Update the Google Fonts font collection URL to the latest version for 6.5.

Reviewed by peterwilsoncc.
Merges [57871] to the 6.5 branch.

Props mmaattiiaass.
Fixes #60819.

Note: See TracTickets for help on using tickets.