Make WordPress Core

Opened 6 weeks ago

Closed 4 weeks ago

#60987 closed enhancement (duplicate)

Twenty Sixteen: Replace frontend jQuery usage with Interactivity API

Reported by: adamsilverstein's profile adamsilverstein Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: needs-patch
Focuses: javascript, performance Cc:

Description

This ticket focuses on removing jQuery as a frontend dependency for Twenty Sixteen when the site is running WordPress >= 6.5 where we can leverage the Interactivity API instead.

This is similar to https://core.trac.wordpress.org/ticket/55126 which proposes replacing jQuery with vanilla JavaScript.

Note:

  • Leveraging the Interactivity API for core themes will help us test and consume our own APIs.
  • The Interactivity API will already be enqueued if any block leveraging the API is used (Query, expanding Search and Navigation for example)
  • Existing code would stay in place for cases where the theme is used on WordPress < 6.5.

Change History (2)

This ticket was mentioned in Slack in #core-performance by adamsilverstein. View the logs.


5 weeks ago

#2 @sabernhardt
4 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #61027.

Let's discuss any possible integrations in (classic) bundled themes on one ticket.

Note: See TracTickets for help on using tickets.