Make WordPress Core

Opened 7 weeks ago

Closed 2 weeks ago

#60991 closed feature request (duplicate)

Could the WP Admin logo reflect the Site Icon instead of the default WordPress logo?

Reported by: leecollings's profile leecollings Owned by:
Milestone: Priority: normal
Severity: minor Version:
Component: Login and Registration Keywords:
Focuses: Cc:

Description

Potentially a small tweak, but one that could be quite a nice visual change.

In the Customiser, the 'Site Icon' is used to feed the favicon for sites.

But could it also serve as the image displayed for the logo on the WP Admin login screen?

As the Site Icon requests images should be at least 512x512 pixels, which is more than enough to display on the login screen, is there any reason why this wouldn't be a good idea?

Attachments (2)

Screenshot 2024-04-11 at 09.28.55.png (32.8 KB) - added by leecollings 7 weeks ago.
WP Admin login screen showing the current default WordPress logo
Screenshot 2024-04-11 at 09.29.52.png (57.5 KB) - added by leecollings 7 weeks ago.
Site Icon within Customiser used for setting site favicon

Download all attachments as: .zip

Change History (7)

@leecollings
7 weeks ago

WP Admin login screen showing the current default WordPress logo

@leecollings
7 weeks ago

Site Icon within Customiser used for setting site favicon

#2 @swissspidy
7 weeks ago

Previously discussed in #33597, it was determined that the site icon isn't suited for this and that the site logo would be more appropriate. In #35807 that was ruled to be plugin territorry. I suggest closing this one as a duplicate.

#3 @leecollings
7 weeks ago

Understand your comments here, and thanks for showing me where it was previously discussed.

I do find it hard to believe both those tickets were 8 years ago, and it's still not been made into a core feature (whether it be icon or logo).

I don't personally agree it should be plugin territory, but at the moment, as I sometimes deal with child themes, I build it into those.

But if I could help possibly push the idea of it becoming a new default feature, that's what I'm trying to push for. Is there anything further I can do to help?

#4 @audrasjb
7 weeks ago

  • Keywords close 2nd-opinion added
  • Type changed from enhancement to feature request

I do find it hard to believe both those tickets were 8 years ago, and it's still not been made into a core feature (whether it be icon or logo).

These tickets were closed as wontfix because it was decided that this change wouldn't be relevant.
FWIW, I'm personally still in favor of keeping this into plugin’s territory.

#5 @sabernhardt
2 weeks ago

  • Keywords close 2nd-opinion removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #35807.

I'll close as a duplicate of the Site Logo ticket.

I would like to replace the WordPress logo and link without a plugin (or customizing the theme), but implementing that in Core could be very tricky. The Site Logo should be more appropriate than the Site Icon on the login page, but we do not know the logo's dimensions to determine a maximum width and/or height (if the image is taller than it is wide). The Site Icon has cropping to enforce a square.

Note: See TracTickets for help on using tickets.