Make WordPress Core

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#61087 closed enhancement (fixed)

Interactivity API: Cannot be used from wp-admin

Reported by: jonsurrell's profile jonsurrell Owned by: jonsurrell's profile jonsurrell
Milestone: 6.6 Priority: normal
Severity: normal Version: 6.5
Component: Interactivity API Keywords: has-patch
Focuses: javascript Cc:

Description

Interactivity API has hooks that run on the frontend, but not in wp-admin. This means that interactivity data is not printed to the HTML and the interactivity Script Modules are not registered.

Related to #61086.

Change History (5)

This ticket was mentioned in PR #6453 on WordPress/wordpress-develop by @jonsurrell.


3 months ago
#1

  • Keywords has-patch added

#2 @jonsurrell
3 months ago

  • Component changed from General to Interactivity API

#3 @gziolo
3 months ago

  • Milestone changed from Awaiting Review to 6.6
  • Version set to 6.5

#4 @gziolo
3 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 58127:

Interactivity API: Cannot be used from wp-admin

Interactivity API has hooks that run on the frontend, but not in wp-admin. This means that interactivity data was not printed to the HTML and the interactivity Script Modules were not registered.

Fixes #61087.
Props jonsurrell, cbravobernal, gziolo.

Note: See TracTickets for help on using tickets.