WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#6129 closed defect (bug) (invalid)

upload.js should reference parent instead of top

Reported by: huwr Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:

Description

line 267 of wp-admin/js/upload.js:

if ( !win )
win = top;

breaks when wp-admin is within a master frame. for example, a cms system may use WP as one component while keeping a CMS navigation frame at the top. this javascript would reference the navigation frame, not the correct WP frame.

this can be fixed by:

if ( !win )
win = parent;

which will reference what it was intended to within any frame hierarchy.

Change History (1)

comment:1 @Denis-de-Bernardy6 years ago

  • Milestone 2.9 deleted
  • Resolution set to invalid
  • Status changed from new to closed

can't find this code any more.

Note: See TracTickets for help on using tickets.