Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#6131 closed defect (bug) (worksforme)

WordPress 2.3.3 /wp-admin/post-new.php will not load properly in linux

Reported by: johncub Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.3.3
Component: Administration Keywords:
Focuses: Cc:


Server setup:

WordPress 2.3.3
hosted on Apache 2.2 win32 Binary without crypto (no_mod_ssl)
php 5.2.5 win32 running as module
mysql 5.0.51a-community-nt-log (hosted externally - win2k3)

Problem description: I already had php, mysql and apache running smoothly before installing wordpress. I installed wordpress, edited the default post and all was well. It was up and running. When I got home and my client was linux / firefox I was able to navigate the pages of my blog but I was not able to post a new entry, ie use /wp-admin/post-new.php. It would start to load the page and hang for as long as was allowed. Even during this time I could log in and go to the same page and post a new post in a windows client while linux was waiting for something. It seemed as though something hated baby linux. :P Windows did not have a problem.

Known software effected
All linux based, FireFox 1.5, FireFox 2.0, FireFox 3 Beta 3, Opera/9.25

Things I did to try to figure out what the problem was:
Initiated packet logging on the linux client then sent the request to the server for /wp-admin/post-new.php
last packet sent was
GET /wordpress/wp-includes/js/jquery/interface.js??ver=1.2 HTTP/1.1

Thusly I turned off javascript in linux to see what would happen. page loaded fine. fancy that.

Later that same day a colleague across the country attempted to post a new entry using linux again to find the same problem: Page would not load unless javascript was turned off.

Tested same software packages on another server (win 2003 corp) with all other factors being the same and was able to reproduce the problem by attempting to post-new.php with a linux/ff client.

Workaround identified (Firefox/linux):
While it could be considered that turning off javascript is a workaround I don't think its one most people would want. My colleague noted that in about:config (firefox) one could change the setting "javascript.options.strict" to true, load the post-new.php, then turn that setting back to false and it will load post-new.php henceforth until your cache is cleared in firefox.

Steps to reproduce

  1. Be on a linux / firefox or opera machine.
  2. Clear your cache
  3. Visit a Wordpress 2.3.3 admin site and attempt to write a new post.
  4. set javascript.options.strict to TRUE
  5. visit the new-post.php and allow the editor to load.
  6. turn javascript.options.strict to FALSE if you like (gets rather verbose otherwise)

Change History (2)

comment:1 @johncub8 years ago

  • Component changed from TinyMCE to Administration
  • Summary changed from WordPress 2.3.3 TinyMce will not load properly in linux to WordPress 2.3.3 /wp-admin/post-new.php will not load properly in linux
  • Version set to 2.3.3

comment:2 @lloydbudd8 years ago

  • Milestone 2.6 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Thanks for participating in WordPress!

Closing as works for me, but could also be closed as won't fix. Please try 2.5 still in development as it has a new version of TinyMCE and 2.3.3 is very unlikely to have further maintenance in this area.

FYI. Linux is my primary OS and it works fine for me and always has.

Note: See TracTickets for help on using tickets.