Make WordPress Core

Opened 8 weeks ago

Closed 8 weeks ago

Last modified 8 weeks ago

#61334 closed defect (bug) (duplicate)

Admin Menu: The admin submenu gets hidden behind the "Theme Details" modal

Reported by: dharm1025's profile Dharm1025 Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.5.3
Component: Administration Keywords:
Focuses: ui, administration Cc:

Description

When the "Theme Details" modal is active, the admin submenu gets hidden behind it. Based on a quick check, it seems the theme overlay (.theme-overlay .theme-backdrop) has a higher z-index than the submenu (#adminmenu .wp-submenu). This is the reason the submenu gets hidden behind the "Theme Details" modal.

https://i.imgur.com/LG7FP9f.png

Steps to Reproduce

  1. Go to Appearance > Themes
  2. Click on any theme to view its details. This will open the "Theme Details" modal to display information about the theme.
  3. Try to navigate to another page by hovering the menu (eg: Settings > General)
  4. Notice submenu is hidden behind the "Theme Details" modal

Expected Results

Submenu should be visible on hover to top-level menu.

https://i.imgur.com/48vLSzk.png

Thank you

Change History (3)

#1 @sabernhardt
8 weeks ago

  • Milestone Awaiting Review deleted

Hi and welcome to WordPress Trac!

We are already tracking the z-index issue in #41155.

#2 @sabernhardt
8 weeks ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #41155.

#3 @Dharm1025
8 weeks ago

Hi @sabernhardt,

Thanks for linking the original issue here and closing this one. I had searched for a similar issue but somehow didn't find it.

Thank you.

Note: See TracTickets for help on using tickets.