Make WordPress Core

Opened 5 weeks ago

Closed 5 weeks ago

#61375 closed defect (bug) (duplicate)

PHP 8.1: Implicit conversion error make it impossible to crop image

Reported by: amanias1977's profile amanias1977 Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.5.3
Component: Media Keywords:
Focuses: Cc:

Description

Hi,
the following log of the error.

[04-Jun-2024 17:45:38 Europe/Rome] PHP Deprecated:  Implicit conversion from float 1132.2 to int loses precision in /app/www/htdocs/wp-includes/class-wp-image-editor-imagick.php on line 623
[04-Jun-2024 17:45:38 Europe/Rome] PHP Deprecated:  Implicit conversion from float 1509.6 to int loses precision in /app/www/htdocs/wp-includes/class-wp-image-editor-imagick.php on line 623
[04-Jun-2024 17:45:38 Europe/Rome] PHP Deprecated:  Implicit conversion from float 231.2 to int loses precision in /app/www/htdocs/wp-includes/class-wp-image-editor-imagick.php on line 623
[04-Jun-2024 17:45:38 Europe/Rome] PHP Deprecated:  Implicit conversion from float 1132.2 to int loses precision in /app/www/htdocs/wp-includes/class-wp-image-editor-imagick.php on line 624
[04-Jun-2024 17:45:38 Europe/Rome] PHP Deprecated:  Implicit conversion from float 1509.6 to int loses precision in /app/www/htdocs/wp-includes/class-wp-image-editor-imagick.php on line 624
[04-Jun-2024 17:47:08 Europe/Rome] PHP Deprecated:  Implicit conversion from float 989.4 to int loses precision in /app/www/htdocs/wp-includes/class-wp-image-editor-imagick.php on line 623
[04-Jun-2024 17:47:08 Europe/Rome] PHP Deprecated:  Implicit conversion from float 1319.2 to int loses precision in /app/www/htdocs/wp-includes/class-wp-image-editor-imagick.php on line 623
[04-Jun-2024 17:47:08 Europe/Rome] PHP Deprecated:  Implicit conversion from float 316.2 to int loses precision in /app/www/htdocs/wp-includes/class-wp-image-editor-imagick.php on line 623
[04-Jun-2024 17:47:08 Europe/Rome] PHP Deprecated:  Implicit conversion from float 989.4 to int loses precision in /app/www/htdocs/wp-includes/class-wp-image-editor-imagick.php on line 624
[04-Jun-2024 17:47:08 Europe/Rome] PHP Deprecated:  Implicit conversion from float 1319.2 to int loses precision in /app/www/htdocs/wp-includes/class-wp-image-editor-imagick.php on line 624

The error make impossible to crop a image in the Media editor.

Tnx

Alessandro

Change History (2)

This ticket was mentioned in Slack in #core-media by joedolson. View the logs.


5 weeks ago

#2 @joedolson
5 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #59782.

Thanks for reporting! This is a duplicate of an existing ticket, so I'm closing it so that discussion remains on the existing ticket.

Note: See TracTickets for help on using tickets.