Make WordPress Core

Opened 6 weeks ago

Closed 5 weeks ago

#61417 closed defect (bug) (reported-upstream)

WordPress 6.6 Beta 2 Font Library Issue

Reported by: nithins53's profile nithins53 Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: has-screenshots has-testing-info needs-patch
Focuses: Cc:

Description

I installed WordPress 6.6 Beta 2 and faced an issue with regard to the font library. The font library works as expected with the currently active theme, but if we switch to another theme and apply the font, the changes are not reflected in the editor but can be seen in the front end. Now if we refresh the editor, we can see the font is applied.

Testing Instructions

Activate Twenty Twenty-Four theme
Upload a font
Activate it for headings and text
The font is reflected properly in the editor and the front end
Now switch to the Twenty Twenty-Three theme
Activate the font
Apply the font
We can see it is not rendered in the editor
Preview the website in a new tab and the font is reflected properly in the front end
Refresh the editor and now we can see that the applied font is properly applied

Testing Environment

  • WordPress: 6.6-beta2-58392
  • PHP: 8.2.4
  • Server: Apache/2.4.56 (Win64) OpenSSL/1.1.1t PHP/8.2.4
  • Database: mysqli (Server: 10.4.28-MariaDB / Client: mysqlnd 8.2.4)
  • Browser: Chrome 109.0.0.0 (Windows 10/11)
  • Theme: Twenty Twenty-Four 1.1
  • MU-Plugins: None activated
  • Plugins:
    • WordPress Beta Tester 3.5.5

Attachments (5)

Editor-2024.png (368.5 KB) - added by thup90 6 weeks ago.
Page-2024.png (268.4 KB) - added by thup90 6 weeks ago.
Editor-2023.png (267.7 KB) - added by thup90 6 weeks ago.
Editor-after-refresh-2023.png (303.8 KB) - added by thup90 6 weeks ago.
Page-2023.png (216.0 KB) - added by thup90 6 weeks ago.

Download all attachments as: .zip

Change History (13)

This ticket was mentioned in Slack in #core-test by thup90. View the logs.


6 weeks ago

@thup90
6 weeks ago

@thup90
6 weeks ago

@thup90
6 weeks ago

@thup90
6 weeks ago

#2 @thup90
6 weeks ago

Reproduction Report

This report validates that the issue can be reproduced.

Environment

  • Web Server: Nginx
  • PHP: 8.2
  • WordPress: 6.6-beta2
  • Browser: Google Chrome Version 125.0.6422.142
  • Theme: Twenty Twenty-Four, Twenty Twenty-Three
  • Active Plugins:
    • WordPress Beta Tester 3.5.5

Actual Results

  • ✅ Replicated the issue with the font not reflected correctly in the editor after Twenty Twenty-three theme was enabled. After refreshing the page, the font displayed correctly.

Additional Notes

  • Replicated the issue with WordPress version 6.5.4 as well.

Supplemental Artifacts

See attachments.

This ticket was mentioned in Slack in #core-test by thup90. View the logs.


6 weeks ago

#4 @krupajnanda
6 weeks ago

@nithins53 I'm able to replicate this issue. Once the font is applied, in the editor we have to one more refresh in order to get them into the effect.

Reproduction Report

Description

This report validates whether the issue can be reproduced.

Environment

  • WordPress: 6.6-beta2-58392-src
  • PHP: 8.2.15
  • Server: nginx/1.25.3
  • Database: mysqli (Server: 8.0.36 / Client: mysqlnd 8.2.15)
  • Browser: Chrome 125.0.0.0
  • OS: macOS
  • Theme: Twenty Twenty-Three 1.4
  • MU Plugins:
    • Safe Autoloaded Options Limit Test (MU Plugin) 1.0
  • Plugins:
    • Test Reports 1.1.0

Actual Results

  • Able to reproduce the given scenario.

#5 @elbsegler
5 weeks ago

I was able to reproduce the error 1:1.
The refresh of the selected font is not displayed immediately.

Browser: Firefox 126.0.1

#6 @krupajnanda
5 weeks ago

  • Component changed from General to Bundled Theme
  • Keywords has-screenshots has-testing-info needs-patch added

#7 @nithi22
5 weeks ago

I could also reproduce the issue.

Environment

  • WordPress: 6.6-beta2
  • PHP: 8.2.0
  • Server: Apache/2.4.54 (Unix) OpenSSL/1.0.2u PHP/8.2.0 mod_wsgi/3.5 Python/2.7.18 mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_perl/2.0.11 Perl/v5.30.1
  • Database: mysqli (Server: 5.7.39 / Client: mysqlnd 8.2.0)
  • Browser: Firefox 127.0 (macOS)
  • Theme: Twenty Twenty-Four 1.1
  • MU-Plugins: None activated
  • Plugins:
    • WordPress Beta Tester 3.5.5

#8 @nithins53
5 weeks ago

  • Resolution set to reported-upstream
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.