Make WordPress Core

Opened 6 weeks ago

Closed 5 weeks ago

Last modified 4 weeks ago

#61432 closed defect (bug) (reported-upstream)

Color for search block does not reflect

Reported by: benniledl's profile benniledl Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.6
Component: Editor Keywords:
Focuses: css Cc:

Description

Bug Report

Description

When you change the color of background or text in the search block it does not reflect neither in the editor nor in the frontend

Environment

  • WordPress: 6.6-beta2-58396
  • PHP: 8.0.30
  • Server: Apache
  • Database: mysqli (Server: 8.0.37 / Client: mysqlnd 8.0.30)
  • Browser: Firefox 126.0
  • Browser: Chrome (latest)
  • OS: Windows 10/11
  • Theme: Twenty Twenty-Four 1.1
  • MU Plugins: None activated
  • Plugins:
    • Test Reports 1.1.0

Steps to Reproduce

  1. Change color of the search block
  2. Look into the frontend
  3. 🐞 Bug occurs. Color does not appear

Expected Results

  1. ✅ Color appears in both frontend and editor

Actual Results

  1. ❌ Color does not appear

Supplemental Artifacts

Screenshots

Change History (15)

This ticket was mentioned in Slack in #core-test by benniledl. View the logs.


6 weeks ago

#2 @krupajnanda
6 weeks ago

  • Keywords 2nd-opinion added; needs-patch removed

@benniledl

I am not able to replicate this issue at my end. Please check the attached video.

Reproduction Report

Description

This report validates whether the issue is not reproduced.

Environment

  • WordPress: 6.6-beta2-58392-src
  • PHP: 8.2.15
  • Server: nginx/1.25.3
  • Database: mysqli (Server: 8.0.36 / Client: mysqlnd 8.2.15)
  • Browser: Chrome 125.0.0.0
  • OS: macOS
  • Theme: Twenty Twenty-Four 1.1
  • MU Plugins:
    • Safe Autoloaded Options Limit Test (MU Plugin) 1.0
  • Plugins:
    • Test Reports 1.1.0

Actual Results

  1. Unable to replicate the behaviour explained by the reporer.

Supplemental Artifacts

Attachment: https://drive.google.com/file/d/1e42YMburZiHQX4Tk-r1GP6LtDYU0HZ7g/view?usp=sharing

#3 @benniledl
6 weeks ago

Hey, @krupajnanda
I see the color does reflect for the button but not the Input field.
When one toggles the button off then the settings render useless.

#4 @krupajnanda
6 weeks ago

@benniledl Could you please share the screen recording of the steps you are following? I am not clear if you are facing issue with Button Text or Background?

#5 @krupajnanda
6 weeks ago

  • Keywords dev-feedback added

@benniledl I think the behaviour is correct as when those properties are for changing the color of the "Search Button" and when there is no button present it would not be reflected anywhere.

There should be a way to handle this scenario when "Search button" isn't present, those style should get disabled.

#6 @benniledl
6 weeks ago

The setting does not explicitely say button color/background. I think we should not disable the settings but rather apply the settings to the input field when no button is present.

#7 @poena
5 weeks ago

Hi

Kindly remember that both bug fixes and enhancements for the editor and the blocks are managed in the Gutenberg GitHub repository and not on Trac.
Therefor, to progress on this type of issue, a new issue needs to be created on GitHub, and this ticket can then be closed.

The color option for this block does only affect the button, that is how the feature is built, and as such the missing color on the input field is not a bug.

If I understand correctly, the scope of this ticket has changed from being a bug report, to a request for an enhancement about when the color option is being displayed?

-The problem with hiding the controls is that for some users, hiding the control would be expected, but for other users it would make it more confusing. There is no ideal solution as different users will have different needs. A middle way would be to display them but as disabled.

#8 @krupajnanda
5 weeks ago

  • Resolution set to invalid
  • Status changed from new to closed

Hey @poena 👋
Thank you for sharing your valuable feedback. Much appreciated! 🙇‍♀️

The problem with hiding the controls is that for some users, hiding the control would be expected, but for other users it would make it more confusing. There is no ideal solution as different users will have different needs. A middle way would be to display them but as disabled.

I agree with what you had suggested here.

I am closing this issue from here. @benniledl would you please create a new ticket on GH?

Thank you! 🙌

#9 @krupajnanda
5 weeks ago

  • Keywords close added

#10 @desrosj
4 weeks ago

  • Keywords 2nd-opinion dev-feedback close removed
  • Milestone Awaiting Review deleted
  • Resolution changed from invalid to reported-upstream

Once an upstream ticket is created, could it just be added here for easy reference?

Note: See TracTickets for help on using tickets.