WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#6165 closed defect (bug) (fixed)

AJAX doesn't work when editing comments on single post

Reported by: mdawaffe Owned by:
Milestone: 2.5 Priority: normal
Severity: normal Version: 2.5
Component: General Keywords: has-patch commit
Focuses: Cc:

Description

  1. Go to Manage -> Posts
  2. Click comment bubble of post with comments.
  3. Unapprove a comment.
  4. Note that page refreshes instead AJAX updating.

The problem is that we enqueue the ajax JS for these single post pages only when the od $_GET['c'] parameter is set.

Attached.

Attachments (3)

6165.diff (615 bytes) - added by mdawaffe 7 years ago.
6165.b.diff (1.3 KB) - added by mdawaffe 7 years ago.
even better
6165-pages.diff (1.6 KB) - added by mdawaffe 7 years ago.
for pages

Download all attachments as: .zip

Change History (5)

@mdawaffe7 years ago

@mdawaffe7 years ago

even better

comment:1 @ryan7 years ago

(In [7247]) Fix AJAX comment ops for single posts. Props mdawaffe. see #6165

@mdawaffe7 years ago

for pages

comment:2 @ryan7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [7248]) Fix AJAX comment ops for single pages. Props mdawaffe. fixes #6165

Note: See TracTickets for help on using tickets.