WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#6183 closed defect (bug) (worksforme)

Quicktags button formatting issues

Reported by: markjaquith Owned by: markjaquith
Milestone: Priority: lowest
Severity: trivial Version: 2.5
Component: Administration Keywords:
Focuses: Cc:

Description

  1. The "code" button is a different height and position than the other buttons
  2. The buttons are using a "square" style that clashes with the nice curved buttons elsewhere in the admin
  3. The buttons are significantly more cramped (lack of padding) in Safari than in Firefox

Safari:

http://img530.imageshack.us/img530/843/safarisz7.png

Firefox:

http://img530.imageshack.us/img530/211/ffsmj7.png

Change History (9)

comment:1 @markjaquith7 years ago

  • Owner changed from anonymous to markjaquith
  • Status changed from new to assigned

Giving #ed_toolbar input {} a height fixes issue 1.

Giving the buttons a class of .button makes them rounded, but then you have to remove the custom background image or it looks funky. Alternatively, we can keep them square and just remove the border to class them up.

comment:2 @sambauers7 years ago

  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #6179, which has a patch

comment:3 @sambauers7 years ago

  • Priority changed from normal to lowest
  • Resolution duplicate deleted
  • Severity changed from normal to trivial
  • Status changed from closed to reopened

Apologies only point 1 of this ticket is a dupe. Re-opening for point 2 and 3.

comment:4 @azaozz7 years ago

What revision are the screenshots from? In http://trac.wordpress.org/changeset/7255
they were fixed for IE6/7 and also tried to make them look more consistent across all browsers.

Bear in mind that the changes have to be tested in FF 2, FF 3 , IE 6, IE 7, Safari 3, Opera 9.2 and Opera 9.5 in Windows, OSX and Linux whenever supported.

comment:5 @Aaron Harun7 years ago

  • Keywords has-patch added

comment:6 @Aaron Harun7 years ago

  • Keywords has-patch removed

comment:7 @markjaquith7 years ago

[7413] screenshots:

FF 2.0.0.12, OS X:

http://img512.imageshack.us/img512/981/ff2oa6.png

Safari 3.1, OS X:

http://img523.imageshack.us/img523/1915/s31iq7.png

comment:8 @lloydbudd7 years ago

  • Milestone changed from 2.5 to 2.6

comment:9 @jacobsantos6 years ago

  • Milestone 2.9 deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

Appears to have been fixed in 2.7.

Note: See TracTickets for help on using tickets.