WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#6196 closed enhancement (fixed)

New action hook for edit.php for plugin authors to add new filter field...

Reported by: nerrad Owned by: westi
Milestone: 2.5 Priority: normal
Severity: blocker Version: 2.5
Component: Administration Keywords: needs-patch regression
Focuses: Cc:

Description

Why? If plugin authors want to be able to add a new field for filtering the posts on the "Manage->Posts" menu they can use this action hook to insert the form field before the submit button.

Currently (2.5 beta 1) it is possible to add a field via the 'restrict_manage_posts' action hook (see attached screenshot for example) but that is a cludgy solution at best and isn't good for user-friendly ui.

(This would be a complement to ticket: #5899)

Attachments (4)

newaddactionfilterfield.JPG (55.1 KB) - added by nerrad 6 years ago.
Example screen shot using 'restrict_manage_posts' action hook
addnewfilterfield-edit.php.diff (527 bytes) - added by nerrad 6 years ago.
suggested implementation
pjw-wp-filter-manage-posts-2.3.php (2.0 KB) - added by westi 6 years ago.
restrict_manage_post plugin which works for 2.3
pjw-wp-filter-manage-posts-2.5.php (1.8 KB) - added by westi 6 years ago.
restrict_manage_post plugin which works for 2.5

Download all attachments as: .zip

Change History (10)

nerrad6 years ago

Example screen shot using 'restrict_manage_posts' action hook

nerrad6 years ago

suggested implementation

comment:1 westi6 years ago

  • Keywords regression? added
  • Milestone changed from 2.6 to 2.5
  • Owner changed from anonymous to westi
  • Severity changed from normal to blocker
  • Status changed from new to assigned

Hmm that looks like restrict_manage_posts may have ended up in the wrong place after the latest changes.

I'll look into this.

comment:2 follow-up: nerrad6 years ago

I don't think restrict_manage_posts is in the wrong place. My understanding is that it's purpose is for adding hook for filtering by type should a plugin author create a new post type. Therefore you'd want restrict_manage_posts to be where it is for adding in the same line as the other post-type filter options.

However, my suggested new action hook would be for plugin authors to add in a new form-field for filtering by a new post-taxonomy in the indicated location. It'd be nice to have the option of the two possible locations for insertion rather than just one (due to the new ui layout)

comment:3 in reply to: ↑ 2 westi6 years ago

  • Keywords needs-patch regression added; has-patch regression? removed

Replying to nerrad:

I don't think restrict_manage_posts is in the wrong place. My understanding is that it's purpose is for adding hook for filtering by type should a plugin author create a new post type. Therefore you'd want restrict_manage_posts to be where it is for adding in the same line as the other post-type filter options.

However, my suggested new action hook would be for plugin authors to add in a new form-field for filtering by a new post-taxonomy in the indicated location. It'd be nice to have the option of the two possible locations for insertion rather than just one (due to the new ui layout)

restrict_manage_post is in the wrong place - trust me I invented it ;-) [4321]

Unfortunately because of the design of the new admin ui where the whole list is inside the form we can't let plugins add there own form.

I think we need to move restrict_manage_post inside the form back where it should be rather than add another hook - and make sure to notify plugin authors that it has changed slightly.

westi6 years ago

restrict_manage_post plugin which works for 2.3

westi6 years ago

restrict_manage_post plugin which works for 2.5

comment:4 westi6 years ago

I have attached two sample plugins.

The first was my original test plugin for this hook when it was introduced and works fine in 2.3

The second is a version which will work for 2.5 once I check in a fix for this hook in the next few minutes.

Please re-open if there are still issues.

comment:5 westi6 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [7274]) Move the restrict_manage_post hook back to a useful place. Fixes #6196.

comment:6 nerrad6 years ago

Works for me :) Thanks!

Note: See TracTickets for help on using tickets.