WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#6198 closed defect (bug) (fixed)

Label for admin color scheme radio buttons doesn't work

Reported by: nbachiyski Owned by:
Milestone: 2.5 Priority: low
Severity: minor Version:
Component: Administration Keywords: has-patch label
Focuses: Cc:

Description

Steps to reproduce:

  • Get [7272]
  • Go to your profile page
  • Use Firefox
  • Try to activate one of the color scheme radio buttons, using the color table or name

Expected: radio button is activated
Actual: it isn't

The problem is that <label> doesn't work with block-level elements inside, even if display: block is specified.

I propose that we use label for the color scheme name only and use a <div> instead of a <label> to structure the options.

Attachments (2)

color-option-label.diff (2.3 KB) - added by nbachiyski 6 years ago.
color-option-label-2.diff (2.6 KB) - added by nbachiyski 6 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 ryan6 years ago

I think the patch needs a refresh now that some other changes went in.

comment:2 nbachiyski6 years ago

Here it is.

comment:3 westi6 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [7291]) Allow you to click on the colours or label to select a colour scheme. Fixes #6198 props nbachiyski.

Note: See TracTickets for help on using tickets.