WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#6206 closed defect (bug) (fixed)

Headers already sent error in media.php

Reported by: darkfate Owned by: andy
Milestone: 2.5 Priority: normal
Severity: blocker Version:
Component: Administration Keywords: bg|has-patch
Focuses: Cc:

Description

Getting headers already sent:

Warning: Cannot modify header information - headers already sent by (output started at C:\Apache2\htdocs\wp\wp-admin\media.php:63) in C:\Apache2\htdocs\wp\wp-includes\pluggable.php on line 687

Attachments (4)

media.php.diff (429 bytes) - added by darkfate 6 years ago.
assume this is what is intended?
6206-css.diff (331 bytes) - added by andy 6 years ago.
fix missing menu items
6206.diff (264 bytes) - added by mdawaffe 6 years ago.
headers error
6206-warning.diff (569 bytes) - added by andy 6 years ago.
default case comes last

Download all attachments as: .zip

Change History (14)

darkfate6 years ago

assume this is what is intended?

comment:1 darkfate6 years ago

  • Keywords has-patch added

comment:2 darkfate6 years ago

  • Keywords bg|has-patch added; has-patch removed

comment:3 mdawaffe6 years ago

I would just put an exit; after the require( 'admin-footer.php' ); for now.

That way browsing to just media.php won't give you a blank page.

comment:4 KirkM6 years ago

I'm still getting the warning message using the test scenario below and although
putting exit; after require( 'admin-footer.php' ); eliminates the "Warning" at the bottom of the image editing page (Manage/Media Library), the "Settings", "Plugins" and "Users" links are still missing from the top of the page. Please see below for details...

In the "Manage/MediaLibrary", when selecting any link in the "Media" column which brings up the selected image's edit page, at that point "Settings", "Plugins" and "Users" links disappear from the top right of page and the following warning is displayed at the bottom of the page on these two sites (same host): (all plugins deactivated-both tests, both sites.

Main site running Trunk build r7331:

Warning*: Cannot modify header information - headers already sent by (output started at /home/longmead/public_html/just-thinkin/wp-admin/admin-header.php:26) in */home/longmead/public_html/just-thinkin/wp-includes/pluggable.php* on line *688

Test site 2 running Trunk build r7298:

*Warning*: Cannot modify header information - headers already sent by (output started at /home/longmead/public_html/just-thinkin/wp25-test/wp-admin/admin-header.php:26) in */home/longmead/public_html/just-thinkin/wp25-test/wp-includes/pluggable.php* on line *687

Since the warning is still showing up, is this really slated to be fixed for version 2.6?


comment:5 ryan6 years ago

  • Owner changed from anonymous to andy

comment:6 darkfate6 years ago

  • Milestone changed from 2.6 to 2.5

comment:7 andy6 years ago

The disappearing menu items are probably due to a CSS conflict on that page. Working on a patch.

comment:8 follow-up: andy6 years ago

I do not see any warnings on that page as of [7345]. Please confirm and give more info on reproducing the problem.

andy6 years ago

fix missing menu items

mdawaffe6 years ago

headers error

andy6 years ago

default case comes last

comment:9 ryan6 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [7346]) Fix warning in media.php. Show sidemenu. Props andy. fixes #6206

comment:10 in reply to: ↑ 8 KirkM6 years ago

Replying to andy:

I do not see any warnings on that page as of [7345]. Please confirm and give more info on reproducing the problem.

Nice job on the fix, Andy but since you asked--as of r7343, the warnings disappeared and only the "sidemenu"(?) was still missing. I just loaded and tested r7346 and all is well. I was away at the moment hence my late reply.

Note: See TracTickets for help on using tickets.